Bug 949132 - NetworkManager-openvpn spec file
NetworkManager-openvpn spec file
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: NetworkManager-openvpn (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity low
: ---
: ---
Assigned To: Dan Williams
Fedora Extras Quality Assurance
:
Depends On:
Blocks: 950282 950283 950285
  Show dependency treegraph
 
Reported: 2013-04-06 01:38 EDT by Dan Fruehauf
Modified: 2013-07-21 20:26 EDT (History)
5 users (show)

See Also:
Fixed In Version: NetworkManager-openvpn-0.9.8.2-2.fc19
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-07-21 20:26:54 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Patch to fix spec file (4.59 KB, patch)
2013-04-06 01:38 EDT, Dan Fruehauf
no flags Details | Diff
Ignore previous patch, use this one. (4.59 KB, patch)
2013-04-06 01:41 EDT, Dan Fruehauf
no flags Details | Diff
Latest patch - 20130410 (4.98 KB, patch)
2013-04-09 22:09 EDT, Dan Fruehauf
no flags Details | Diff
Patch to fix spec file (4.98 KB, patch)
2013-04-11 08:35 EDT, Dan Fruehauf
no flags Details | Diff

  None (edit)
Description Dan Fruehauf 2013-04-06 01:38:28 EDT
Created attachment 732075 [details]
Patch to fix spec file

Description of problem:
NetworkManager-openvpn spec file does not conform to many Fedora Packaging guidelines

Version-Release number of selected component (if applicable):


How reproducible:
Look at spec file

Steps to Reproduce:
1. Includes for instance '%define' instead of '%global' and more
  
Actual results:
I'm providing a patch which brings NetworkManager-openvpn.spec to a better state and also splits it into NetworkManager-openvpn and NetworkManager-openvpn-gnome

Expected results:


Additional info:
I've gone through the process of changing NetworkManager-ssh.spec (based on NetworkManager-openvpn.spec) to conform with Fedora packaging standards and decided it'll be a good idea to implement these changes for the rest of the NetworkManager-* VPN plugins out there.
Comment 1 Dan Fruehauf 2013-04-06 01:41:21 EDT
Created attachment 732076 [details]
Ignore previous patch, use this one.
Comment 2 Dan Fruehauf 2013-04-09 22:09:56 EDT
Created attachment 733440 [details]
Latest patch - 20130410
Comment 3 Dan Fruehauf 2013-04-11 08:35:33 EDT
Created attachment 734159 [details]
Patch to fix spec file
Comment 4 Dan Fruehauf 2013-04-11 08:36:56 EDT
Note about patch:
Contains a deliberate error (TODO) and needs to be replaced with latest known version, because of the package split. As Dan (Williams) mentioned, it is mandatory for updates to work correctly.
Comment 5 Fedora Update System 2013-07-17 10:52:35 EDT
NetworkManager-openvpn-0.9.8.2-2.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/NetworkManager-openvpn-0.9.8.2-2.fc19
Comment 6 Fedora Update System 2013-07-18 01:59:09 EDT
Package NetworkManager-openvpn-0.9.8.2-2.fc19:
* should fix your issue,
* was pushed to the Fedora 19 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing NetworkManager-openvpn-0.9.8.2-2.fc19'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-13177/NetworkManager-openvpn-0.9.8.2-2.fc19
then log in and leave karma (feedback).
Comment 7 Fedora Update System 2013-07-21 20:26:54 EDT
NetworkManager-openvpn-0.9.8.2-2.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.