Bug 949262 - qucs, kicad (eeschema, pcbnew), pikdev and piklab are not in the correct Electronics submenu
Summary: qucs, kicad (eeschema, pcbnew), pikdev and piklab are not in the correct Elec...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora EPEL
Classification: Fedora
Component: electronics-menu
Version: el6
Hardware: All
OS: Linux
unspecified
medium
Target Milestone: ---
Assignee: Chitlesh GOORAH
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-04-07 10:13 UTC by Alain Portal
Modified: 2013-04-27 02:05 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2013-04-18 02:31:17 UTC
Type: Bug


Attachments (Terms of Use)
Places several desktop entries in the correct submenus (1.74 KB, patch)
2013-04-07 10:13 UTC, Alain Portal
no flags Details | Diff
Fixes two typo in Electronics directory file (465 bytes, patch)
2013-04-07 10:15 UTC, Alain Portal
no flags Details | Diff
Frenchifies the Electronics submenus (2.90 KB, patch)
2013-04-07 10:17 UTC, Alain Portal
no flags Details | Diff
Patch for the spec file to apply previous patches (2.13 KB, patch)
2013-04-07 10:21 UTC, Alain Portal
no flags Details | Diff

Description Alain Portal 2013-04-07 10:13:12 UTC
Created attachment 732316 [details]
Places several desktop entries in the correct submenus

Description of problem:

qucs, kicad (eeschema, pcbnew), pikdev and piklab are all in the Electronics menu, not in their respective submenus.

Version-Release number of selected component (if applicable):

1.0-7

How reproducible:

Always

Steps to Reproduce:
1. Install qucs, kicad, pikdev, piklab and electronics-menu
  
Actual results:

qucs, kicad, eeschema, pcbnew menu entries are in Electronics menu

Expected results:

qucs should be in Electronics->Circuit Simulation
kicad, eeschema and pcbnew should be in Electronics->Circuit and PCB design
pikdev and piklab should be in Electronics->Embedded

Additional info:

Original electronics-menu source package is no more available from URL provided in the spec file, perhaps we should own an update a such source archive.

Comment 1 Alain Portal 2013-04-07 10:15:46 UTC
Created attachment 732317 [details]
Fixes two typo in Electronics directory file

Comment 2 Alain Portal 2013-04-07 10:17:35 UTC
Created attachment 732320 [details]
Frenchifies the Electronics submenus

Comment 3 Alain Portal 2013-04-07 10:21:44 UTC
Created attachment 732321 [details]
Patch for the spec file to apply previous patches

This patch for the spec file applies previous patch and frenchifies the spec file.

Comment 4 Alain Portal 2013-04-07 10:59:50 UTC
The bug has been reported for the el6 branch but applies to all branches.
Patches apply only to el6, f17 and f18 branches.
Extra work is needed for f19 and devel branches because of the removing of "vendor" in the desktop file.

Comment 5 Fedora Update System 2013-04-08 20:35:05 UTC
electronics-menu-1.0-10.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/electronics-menu-1.0-10.fc17

Comment 6 Fedora Update System 2013-04-08 20:35:18 UTC
electronics-menu-1.0-8.el6 has been submitted as an update for Fedora EPEL 6.
https://admin.fedoraproject.org/updates/electronics-menu-1.0-8.el6

Comment 7 Fedora Update System 2013-04-08 20:35:30 UTC
electronics-menu-1.0-11.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/electronics-menu-1.0-11.fc18

Comment 8 Fedora Update System 2013-04-09 18:15:22 UTC
Package electronics-menu-1.0-8.el6:
* should fix your issue,
* was pushed to the Fedora EPEL 6 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=epel-testing electronics-menu-1.0-8.el6'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-EPEL-2013-0937/electronics-menu-1.0-8.el6
then log in and leave karma (feedback).

Comment 9 Fedora Update System 2013-04-18 02:31:20 UTC
electronics-menu-1.0-10.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 10 Fedora Update System 2013-04-18 02:32:36 UTC
electronics-menu-1.0-11.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 11 Fedora Update System 2013-04-27 02:05:25 UTC
electronics-menu-1.0-8.el6 has been pushed to the Fedora EPEL 6 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.