Bug 949681 - Password decryption failures due to threading synchronization issue
Password decryption failures due to threading synchronization issue
Status: CLOSED ERRATA
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine (Show other bugs)
3.1.2
Unspecified Unspecified
unspecified Severity high
: ---
: 3.1.4
Assigned To: Alon Bar-Lev
Tareq Alayan
infra
: ZStream
Depends On: 905834
Blocks: 915537
  Show dependency treegraph
 
Reported: 2013-04-08 14:41 EDT by Idith Tal-Kohen
Modified: 2016-02-10 14:14 EST (History)
16 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Unsafe usage of the base64 decoder class caused the decryption buffer to become corrupted, producing "failed to decrypt" error messages on hosts with power management configured. This update removes unsafe and unnecessary encoding classes, so the decryption errors no longer appear.
Story Points: ---
Clone Of: 905834
Environment:
Last Closed: 2013-05-01 14:35:29 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Infra
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Knowledge Base (Solution) 382343 None None None Never
oVirt gerrit 11495 None None None Never
oVirt gerrit 11497 None None None Never
oVirt gerrit 11498 None None None Never
oVirt gerrit 11596 None None None Never

  None (edit)
Comment 1 Alon Bar-Lev 2013-04-09 07:56:37 EDT
Not to QE: please test spice ticketing as well.
Comment 9 errata-xmlrpc 2013-05-01 14:35:29 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0773.html

Note You need to log in before you can comment on or make changes to this bug.