Bug 950007 - fsck.vfat 100% CPU, no read()
Summary: fsck.vfat 100% CPU, no read()
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: dosfstools
Version: 19
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Jaroslav Škarvada
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 950012 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-04-09 13:04 UTC by Harald Hoyer
Modified: 2013-05-06 04:28 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2013-05-06 04:28:10 UTC


Attachments (Terms of Use)

Description Harald Hoyer 2013-04-09 13:04:44 UTC
Description of problem:
Trying to fsck my /dev/sda1 lets fsck.vfat consume 100% CPU without any disk reads.

strace does not show any syscalls after some read().

Version-Release number of selected component (if applicable):
dosfstools-3.0.16-2.fc19.x86_64

I dd'ed and xz'ed the partition image. Maybe you can debug fsck.vfat with that.

Dropbox link sent to jskarvad@redhat.com in private chat. Please only share with debuggers.

Comment 1 Jaroslav Škarvada 2013-05-03 13:34:04 UTC
It does seem as ABI mismatch and it seems it was resolved by the latest rebuild. I am unable to reproduce it with the dosfstools-3.0.16-3.fc19.

I rechecked with the valgrind, there are some memory leaks due to poor coding (I am going to resolve them later), but none of them should be fatal.

Comment 2 Jaroslav Škarvada 2013-05-03 13:36:13 UTC
*** Bug 950012 has been marked as a duplicate of this bug. ***

Comment 3 Fedora Update System 2013-05-03 13:40:29 UTC
dosfstools-3.0.16-3.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/FEDORA-2013-7251/dosfstools-3.0.16-3.fc19

Comment 4 Jaroslav Škarvada 2013-05-03 13:42:54 UTC
I added this BZ to dosfstools-3.0.16-3.fc19 errata, feel free to reopen if the problem persists.

Comment 5 Fedora Update System 2013-05-06 04:28:11 UTC
dosfstools-3.0.16-3.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.