Bug 950022 - BootLoaderError: failed to remove old efi boot entry
Summary: BootLoaderError: failed to remove old efi boot entry
Keywords:
Status: CLOSED DUPLICATE of bug 947142
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda
Version: 19
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Peter Jones
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:637383df30bd07157fdf78056cf...
Depends On:
Blocks: F19Alpha, F19AlphaBlocker
TreeView+ depends on / blocked
 
Reported: 2013-04-09 13:24 UTC by Kamil Páral
Modified: 2013-04-11 00:06 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2013-04-10 16:52:51 UTC
Type: ---


Attachments (Terms of Use)
File: anaconda.log (12.25 KB, text/plain)
2013-04-09 13:25 UTC, Kamil Páral
no flags Details
File: backtrace (1015 bytes, text/plain)
2013-04-09 13:25 UTC, Kamil Páral
no flags Details
File: environ (778 bytes, text/plain)
2013-04-09 13:25 UTC, Kamil Páral
no flags Details
File: ifcfg.log (573 bytes, text/plain)
2013-04-09 13:26 UTC, Kamil Páral
no flags Details
File: lsblk_output (3.41 KB, text/plain)
2013-04-09 13:26 UTC, Kamil Páral
no flags Details
File: nmcli_dev_list (3.73 KB, text/plain)
2013-04-09 13:26 UTC, Kamil Páral
no flags Details
File: packaging.log (683.79 KB, text/plain)
2013-04-09 13:26 UTC, Kamil Páral
no flags Details
File: program.log (57.43 KB, text/plain)
2013-04-09 13:26 UTC, Kamil Páral
no flags Details
File: storage.log (194.41 KB, text/plain)
2013-04-09 13:26 UTC, Kamil Páral
no flags Details
File: syslog (159.92 KB, text/plain)
2013-04-09 13:27 UTC, Kamil Páral
no flags Details
File: anaconda-tb (1.14 MB, text/plain)
2013-04-09 13:27 UTC, Kamil Páral
no flags Details

Description Kamil Páral 2013-04-09 13:24:39 UTC
Description of problem:
This happened during "installing bootloader". F19 Alpha RC1 DVD->USB (dd) run in UEFI mode. Probably related to bug 947142.
The following was filed automatically by anaconda:
anaconda 19.16-1 exception report
Traceback (most recent call first):
  File "/usr/lib64/python2.7/site-packages/pyanaconda/bootloader.py", line 1642, in remove_efi_boot_target
    raise BootLoaderError("failed to remove old efi boot entry")
  File "/usr/lib64/python2.7/site-packages/pyanaconda/bootloader.py", line 1670, in install
    self.remove_efi_boot_target()
  File "/usr/lib64/python2.7/site-packages/pyanaconda/bootloader.py", line 1690, in write
    self.install()
  File "/usr/lib64/python2.7/site-packages/pyanaconda/bootloader.py", line 2246, in writeBootLoader
    storage.bootloader.write()
  File "/usr/lib64/python2.7/site-packages/pyanaconda/install.py", line 141, in doInstall
    writeBootLoader(storage, payload, instClass, ksdata)
  File "/usr/lib64/python2.7/threading.py", line 504, in run
    self.__target(*self.__args, **self.__kwargs)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/threads.py", line 141, in run
    threading.Thread.run(self, *args, **kwargs)
BootLoaderError: failed to remove old efi boot entry

Version-Release number of selected component:
anaconda-19.16-1

Additional info:
cmdline:        /usr/bin/python  /sbin/anaconda
cmdline_file:   BOOT_IMAGE=/images/pxeboot/vmlinuz inst.stage2=hd:LABEL=Fedora\x2019-Alpha\x20x86_64 quiet
executable:     /sbin/anaconda
hashmarkername: anaconda
kernel:         3.9.0-0.rc4.git0.1.fc19.x86_64
product:        Fedora
release:        Cannot get release name.
type:           anaconda
version:        19-Alpha

Truncated backtrace:
Traceback (most recent call last):
  File "/usr/lib64/python2.7/site-packages/pyanaconda/threads.py", line 141, in run
    threading.Thread.run(self, *args, **kwargs)
  File "/usr/lib64/python2.7/threading.py", line 504, in run
    self.__target(*self.__args, **self.__kwargs)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/install.py", line 141, in doInstall
    writeBootLoader(storage, payload, instClass, ksdata)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/bootloader.py", line 2246, in writeBootLoader
    storage.bootloader.write()
  File "/usr/lib64/python2.7/site-packages/pyanaconda/bootloader.py", line 1690, in write
    self.install()
  File "/usr/lib64/python2.7/site-packages/pyanaconda/bootloader.py", line 1670, in install
    self.remove_efi_boot_target()
  File "/usr/lib64/python2.7/site-packages/pyanaconda/bootloader.py", line 1642, in remove_efi_boot_target
    raise BootLoaderError("failed to remove old efi boot entry")
BootLoaderError: failed to remove old efi boot entry

Comment 1 Kamil Páral 2013-04-09 13:25:44 UTC
Created attachment 733215 [details]
File: anaconda.log

Comment 2 Kamil Páral 2013-04-09 13:25:54 UTC
Created attachment 733216 [details]
File: backtrace

Comment 3 Kamil Páral 2013-04-09 13:25:58 UTC
Created attachment 733217 [details]
File: environ

Comment 4 Kamil Páral 2013-04-09 13:26:08 UTC
Created attachment 733218 [details]
File: ifcfg.log

Comment 5 Kamil Páral 2013-04-09 13:26:18 UTC
Created attachment 733219 [details]
File: lsblk_output

Comment 6 Kamil Páral 2013-04-09 13:26:21 UTC
Created attachment 733220 [details]
File: nmcli_dev_list

Comment 7 Kamil Páral 2013-04-09 13:26:36 UTC
Created attachment 733221 [details]
File: packaging.log

Comment 8 Kamil Páral 2013-04-09 13:26:49 UTC
Created attachment 733223 [details]
File: program.log

Comment 9 Kamil Páral 2013-04-09 13:26:56 UTC
Created attachment 733224 [details]
File: storage.log

Comment 10 Kamil Páral 2013-04-09 13:27:01 UTC
Created attachment 733225 [details]
File: syslog

Comment 11 Kamil Páral 2013-04-09 13:27:12 UTC
Created attachment 733226 [details]
File: anaconda-tb

Comment 12 Kamil Páral 2013-04-10 16:40:33 UTC
Proposing as an Alpha blocker. In order to get a cookie from tflink, here's the criterion:
"All release-blocking images must boot in their supported configurations. 
Release-blocking images must boot from all system firmware types that are commonly found on the primary architectures."
http://fedoraproject.org/wiki/Fedora_19_Alpha_Release_Criteria

Comment 13 Matthew Garrett 2013-04-10 16:52:51 UTC
8000000000000009 is OUT_OF_RESOURCES, so looks like a dupe.

*** This bug has been marked as a duplicate of bug 947142 ***

Comment 14 Adam Williamson 2013-04-11 00:06:00 UTC
My RC2 test install on my UEFI test system failed and came up as a dupe of this one.


Note You need to log in before you can comment on or make changes to this bug.