Bug 950093 - upstream patches needed for aarch64 support in glibc
upstream patches needed for aarch64 support in glibc
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: glibc (Show other bugs)
19
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Carlos O'Donell
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-04-09 11:31 EDT by Mark Salter
Modified: 2013-11-06 22:32 EST (History)
8 users (show)

See Also:
Fixed In Version: glibc-2.17-19.fc19
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-11-06 22:32:50 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
patches for aarch64 support (14.32 KB, patch)
2013-04-09 11:31 EDT, Mark Salter
no flags Details | Diff

  None (edit)
Description Mark Salter 2013-04-09 11:31:58 EDT
Created attachment 733271 [details]
patches for aarch64 support

Description of problem:
Some recent upstream patches sorting out /lib vs /lib64 are needed for aarch64 support. I have attached a single patch which contains the needed upstream patches and spec file changes to wire them in. I have built and am using this set of patches for glibc in the aarch64 bootstrap. Could we get this patch or similar into f19, please?

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Carlos O'Donell 2013-10-28 17:53:15 EDT
This is fixed in rawhide.

This is also fixed in fedora 20.

It is *now* fixed in fedora 19.

I added some additional patches for s390x that were required.

This bug is now in MODIFIED.
Comment 2 Fedora Update System 2013-10-28 20:50:49 EDT
glibc-2.17-19.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/glibc-2.17-19.fc19
Comment 3 Fedora Update System 2013-10-29 21:52:20 EDT
Package glibc-2.17-19.fc19:
* should fix your issue,
* was pushed to the Fedora 19 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing glibc-2.17-19.fc19'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-20264/glibc-2.17-19.fc19
then log in and leave karma (feedback).
Comment 4 Fedora Update System 2013-11-06 22:32:50 EST
glibc-2.17-19.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.