Bug 950122 - Missing description of -batch in man page of tc command
Summary: Missing description of -batch in man page of tc command
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: iproute
Version: 6.4
Hardware: All
OS: Linux
unspecified
low
Target Milestone: rc
: ---
Assignee: Petr Šabata
QA Contact: David Spurek
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-04-09 17:03 UTC by Hubert Kario
Modified: 2015-03-02 05:27 UTC (History)
3 users (show)

Fixed In Version: iproute-2.6.32-24.el6
Doc Type: Bug Fix
Doc Text:
Cause: The tc utility documentation was lacking description of the batch option. Consequence: Poor documentation leads to user frustration. Fix: The description of the -batch option was added to the manpage. Result: General documentation improvements.
Clone Of:
Environment:
Last Closed: 2013-11-21 23:04:48 UTC


Attachments (Terms of Use)
add short description of batch mode in tc man page (1.24 KB, patch)
2013-04-11 14:52 UTC, Hubert Kario
no flags Details | Diff


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2013:1697 normal SHIPPED_LIVE iproute bug fix and enhancement update 2013-11-21 00:39:29 UTC

Description Hubert Kario 2013-04-09 17:03:14 UTC
Description of problem:
Man page of tc doesn't describe usage of -batch option while output from 'tc -help' does mention it.

Version-Release number of selected component (if applicable):
iproute-2.6.32-23.el6.x86_64

How reproducible:
Always

Steps to Reproduce:
1. man tc
2. search for batch
3.
  
Actual results:
No description found

Expected results:
Description on how it's used, what are the possible inputs, etc.

Additional info:
The bug is present in Fedora 18 too, so it's quite likely not fixed upstream and present in all distributions.

Comment 1 Hubert Kario 2013-04-11 14:52:58 UTC
Created attachment 734273 [details]
add short description of batch mode in tc man page

I've prepared a simple patch of the man page to add short description of -batch and -force switches.

The patch was also sent to iproute2 mailing list and man page maintainer.

Comment 2 Petr Šabata 2013-04-24 09:16:50 UTC
(In reply to comment #1)
> The patch was also sent to iproute2 mailing list and man page maintainer.

Patch is upstream (ce93fff).

Thanks, Hubert.
Requesting acks.

Comment 8 Petr Šabata 2013-08-13 16:18:46 UTC
Pushed as iproute-2.6.32-24.el6.

Comment 12 errata-xmlrpc 2013-11-21 23:04:48 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1697.html


Note You need to log in before you can comment on or make changes to this bug.