Bug 950310 - Long component lists cause a performance and usability problem (e.g. Fedora's components)
Summary: Long component lists cause a performance and usability problem (e.g. Fedora's...
Keywords:
Status: CLOSED DUPLICATE of bug 950315
Alias: None
Product: Bugzilla
Classification: Community
Component: User Interface
Version: 4.2
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Simon Green
QA Contact: tools-bugs
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-04-10 04:34 UTC by Roman Joost
Modified: 2014-10-12 22:50 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2013-04-15 04:04:59 UTC


Attachments (Terms of Use)

Description Roman Joost 2013-04-10 04:34:39 UTC
Description of problem:
The performance report from Jason identified a problem with the page load when filing/querying Fedora specific bugs. The Fedora component list shows more than 16000 entries and growing.

This causes a performance problem and a usability problem.

More information:

https://engineering.redhat.com/trac/eng-infra/wiki/PerformanceReportBugzillaFeb2013#a3.3VariableContentinBugzillasHTMLpages

How reproducible:
100%


Steps to Reproduce:
1. File a new bug report against Fedora and choose a component.
  
Actual results:
The selection is too long.

Expected results:
A shorter or rather narrowed down list of components.

Additional info:
Specification on how to implement this follows.

Comment 1 Simon Green 2013-04-15 04:04:59 UTC

*** This bug has been marked as a duplicate of bug 950315 ***


Note You need to log in before you can comment on or make changes to this bug.