Bug 950617 - [NetKVM] Enable RSS for Windows 2008 R2 as well
Summary: [NetKVM] Enable RSS for Windows 2008 R2 as well
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: virtio-win
Version: 6.5
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Dmitry Fleytman
QA Contact: Virtualization Bugs
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-04-10 13:52 UTC by Yan Vugenfirer
Modified: 2013-12-06 07:42 UTC (History)
10 users (show)

(edit)
Feature: 
Implement RSS (receive side scaling).

Reason: 
RSS improves RX performance on SMP guests.

Result (if any): 
RX performance improved on SMP guests.
Clone Of:
(edit)
Last Closed: 2013-11-22 00:07:46 UTC


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2013:1729 normal SHIPPED_LIVE virtio-win bug fix and enhancement update 2013-11-21 00:39:25 UTC

Description Yan Vugenfirer 2013-04-10 13:52:42 UTC
Description of problem:
Currently RSS implemented for Windows 2012 only. 
Enable it for Windows 2008 RS as well.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

Comment 1 Yan Vugenfirer 2013-04-10 16:49:41 UTC
How to test:

Please run HCK RSS related tests on Windows 2008 R2.

Comment 3 Yan Vugenfirer 2013-04-18 08:29:33 UTC
How to test:

Run RSS related HCK tests on Windows 2008 R2.

Comment 5 lijin 2013-06-21 08:15:49 UTC
in build 59,win2k8-R2 guest can run RSS test:
NDISTest 6.0 - [1 Machine] - 1c_Mini6RSSOids
NDISTest 6.0 - [2 Machine] - 2c_Mini6RSSSendRecv

based on above,this issue has been resolved.

Comment 6 lijin 2013-06-21 08:43:18 UTC
(In reply to lijin from comment #5)
> in build 59,win2k8-R2 guest can run RSS test:
> NDISTest 6.0 - [1 Machine] - 1c_Mini6RSSOids
> NDISTest 6.0 - [2 Machine] - 2c_Mini6RSSSendRecv
> 
> based on above,this issue has been resolved.

Since win2k8-R2 can run this two RSS case,but job "NDISTest 6.0 - [2 Machine] - 2c_Mini6RSSSendRecv" failed to pass HCK test as bug960844, https://bugzilla.redhat.com/show_bug.cgi?id=960844,re-assign this bug

Comment 7 Mike Cao 2013-06-21 08:58:55 UTC
Move status to VERIFIED as RSS code was added in the driver 
Let's use https://bugzilla.redhat.com/show_bug.cgi?id=960844 to rack the failed issue

Comment 12 errata-xmlrpc 2013-11-22 00:07:46 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1729.html


Note You need to log in before you can comment on or make changes to this bug.