Bug 950623 - [NetKVM] Review "TestOnly" parameters and remove those that shouldn't be exposed to the user
Summary: [NetKVM] Review "TestOnly" parameters and remove those that shouldn't be expo...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: virtio-win
Version: 6.5
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Yan Vugenfirer
QA Contact: Virtualization Bugs
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-04-10 13:58 UTC by Yan Vugenfirer
Modified: 2013-12-06 07:42 UTC (History)
8 users (show)

Fixed In Version: virtio-win-prewhql-0.1-59
Doc Type: Bug Fix
Doc Text:
Cause: Debug parameters were exposed to the user. Consequence: User could have change those parameters without fully understanding the consequence of the actions and thus break network device functionality. Fix: Remove test parameters from device manager. Result: User no longer is exposed to debug and experimental parameters.
Clone Of:
Environment:
Last Closed: 2013-11-22 00:07:54 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2013:1729 normal SHIPPED_LIVE virtio-win bug fix and enhancement update 2013-11-21 00:39:25 UTC

Description Yan Vugenfirer 2013-04-10 13:58:06 UTC
Description of problem:

We are exposing several debug parameters for NetKVM driver. They should be reviewed and those that are not used or can cause a user confusion should be removed.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

Comment 5 Yan Vugenfirer 2013-04-10 23:29:06 UTC
Removing "Init.UseMergedBuffers". The guest will always try to use mergable buffer (the check if the host suppors this feature remains in the code):

http://git.engineering.redhat.com/?p=users/yvugenfi/internal-kvm-guest-drivers-windows/.git;a=commit;h=ad2356ced698f02a073f2ec276f8890a423bbd5e

Comment 8 Yan Vugenfirer 2013-04-11 10:40:37 UTC
Removing "Init.UsePublishEvents", will check host settings:

http://git.engineering.redhat.com/?p=users/yvugenfi/internal-kvm-guest-drivers-windows/.git;a=commit;h=1f4faf7957135e5732ef081b38f55ea2c7874cf5

Comment 12 Yan Vugenfirer 2013-04-11 11:24:33 UTC
The change is for drivers for Vista and up. Windows XP and Windows 2003 will have "old" parameters.

Comment 13 Min Deng 2013-04-25 03:09:14 UTC
   Re-test the bug on win7/8/2k8/2012 platform via build 59,the above parameters has been removed.
   Actual results,the parameters were removed
   Expected results,the parameters are removed
   So the issue has been fixed,thanks.

Comment 14 Mike Cao 2013-05-30 03:34:42 UTC
Based on comment #13 ,move status to VERIFIED.

Comment 21 errata-xmlrpc 2013-11-22 00:07:54 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1729.html


Note You need to log in before you can comment on or make changes to this bug.