Bug 950647 - error in the checkpidfile() function of the init script
Summary: error in the checkpidfile() function of the init script
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: tomcat6
Version: 6.0
Hardware: Unspecified
OS: Linux
unspecified
low
Target Milestone: rc
: ---
Assignee: David Knox
QA Contact: tomcat-qe
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-04-10 14:51 UTC by Fabrice Bessettes
Modified: 2018-12-03 18:39 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2013-11-21 23:51:04 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2013:1721 normal SHIPPED_LIVE tomcat6 bug fix update 2013-11-20 21:51:34 UTC

Description Fabrice Bessettes 2013-04-10 14:51:46 UTC
Description of problem:
The output of the status option of the init script is always "lockfile exists but process is not running"

Version-Release number of selected component (if applicable):
tomcat6-6.0.24-52.el6_4.noarch

How reproducible:
Run a tomcat instance, and try service tomcat6 status

Patch:
*************** function checkpidfile()
*** 231,236 ****                       
--- 231,237 ----                       
        if [ -d "/proc/${kpid}" ]; then
  # The pid file exists and the process is running  
            RETVAL="0"                              
+         return                                    
        else                                        
  # The pid file exists but the process is not running
           RETVAL="1"

Comment 4 errata-xmlrpc 2013-11-21 23:51:04 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1721.html


Note You need to log in before you can comment on or make changes to this bug.