Bug 950748 - /lib64/libproc.so package both in procps and procps-devel, unable to build packages depending on it
Summary: /lib64/libproc.so package both in procps and procps-devel, unable to build pa...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: procps
Version: 6.5
Hardware: All
OS: Linux
medium
high
Target Milestone: rc
: ---
Assignee: Jaromír Cápík
QA Contact: Martin Frodl
URL:
Whiteboard:
Depends On:
Blocks: 905255 1119255
TreeView+ depends on / blocked
 
Reported: 2013-04-10 19:20 UTC by Simone Caronni
Modified: 2014-10-14 08:21 UTC (History)
6 users (show)

Fixed In Version: procps-3.2.8-26.el6
Doc Type: Bug Fix
Doc Text:
Clone Of:
: 1119255 (view as bug list)
Environment:
Last Closed: 2014-10-14 08:21:52 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2014:1595 normal SHIPPED_LIVE procps bug fix and enhancement update 2014-10-14 01:39:48 UTC

Description Simone Caronni 2013-04-10 19:20:08 UTC
Description of problem:
File /lib64/libproc.so is provided by both procps and procps-devel (packaging error).

Version-Release number of selected component (if applicable):
procps-3.2.8-25.el6.x86_64
procps-devel-3.2.8-25.el6.x86_64

How reproducible:
Always

Steps to Reproduce:
1. Try to build a package with mock that depends on procps-devel
  
Actual results:
You cannot install procps-devel, as the file libproc.so is contained in both procps and procps-devel.

Installing the package through yum works, as ldconfig recreates the symlinks.

Expected results:
libproc.so is contained only in procps-devel.

Additional info:

yum provides \*libproc.so

procps-3.2.8-25.el6.i686 : System and process monitoring utilities
Repo        : base
Matched from:
Filename    : /lib/libproc.so

procps-devel-3.2.8-25.el6.x86_64 : System and process monitoring utilities
Repo        : base
Matched from:
Filename    : /lib64/libproc.so

procps-3.2.8-25.el6.x86_64 : System and process monitoring utilities
Repo        : base
Matched from:
Filename    : /lib64/libproc.so


Using mock to rebuild:

Transaction Check Error:
  file /lib64/libproc.so from install of procps-devel-3.2.8-25.el6.x86_64 conflicts with file from package procps-3.2.8-25.el6.x86_64

Comment 1 Simone Caronni 2013-04-10 19:23:06 UTC
Building packages with mock or koji produces the error.

Comment 3 Simone Caronni 2013-04-17 13:20:40 UTC
Hello, any news on this?

Thanks,
--Simone

Comment 4 Panu Matilainen 2013-04-25 07:25:24 UTC
This clearly is a packaging bug and should be fixed, but there are rpm bugs at play as well:

1) Permission mode bits are not applicaple to symlinks, but rpmbuild lets %attr and %defattr affect the mode of symlinks
2) rpm >= 4.10 considers different permission mode as a conflict. Symlinks have no meaningful mode and they normally never conflict but due to 1) packaged symlinks can have irregular mode bits set, causing the conflict. Mode bits on symlinks should not be considered when determining file conflicts.

Both 1 and 2 have now been fixed rpm upstream and can be expected to land in Fedora soonish, which will make the conflict go away.

Comment 5 Ondrej Vasik 2013-04-26 07:08:10 UTC
Hello Simone, thanks for this bugreport. We appreciate the feedback and look to use reports such as this to guide our efforts at improving our products. That being said, this bug tracking system is not a mechanism for requesting support, and we are not able to  guarantee the timeliness or suitability of a resolution.

If this issue is critical or in any way time sensitive, please raise a ticket through your regular Red Hat support channels to make certain  it receives the proper attention and prioritization to assure a timely resolution.      

For information on how to contact the Red Hat production support team, please visit:
      https://www.redhat.com/support/process/production/#howto

(This should answer your question on fedora-devel list)

Comment 11 errata-xmlrpc 2014-10-14 08:21:52 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-1595.html


Note You need to log in before you can comment on or make changes to this bug.