Bug 950806 - Notification links disappear from list when detail is viewed
Summary: Notification links disappear from list when detail is viewed
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Zanata
Classification: Retired
Component: Component-UI
Version: 2.3
Hardware: Unspecified
OS: Unspecified
unspecified
low
Target Milestone: ---
: 2.3
Assignee: Alex Eng
QA Contact: Ding-Yi Chen
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-04-11 00:58 UTC by David Mason
Modified: 2013-11-27 03:35 UTC (History)
2 users (show)

Fixed In Version: 2.3-SNAPSHOT (20130423-1233)
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-11-27 03:23:12 UTC


Attachments (Terms of Use)

Description David Mason 2013-04-11 00:58:56 UTC
Description of problem:
Links next to notifications (e.g. for undo or go-to-row) is initially shown, but if the other text of the notification is clicked to bring up a detail dialog for the notification, the link disappears from the main notification list.
The link can still be accessed by opening the detail dialog.


Additional info:
This is caused by the same InlineLink object being passed to the dialog. When the InlineLink is added to the dialog, it is moved and no longer present in the list. Recommend adding clone() method to InlineLink

Comment 1 Alex Eng 2013-04-22 23:54:01 UTC
Issue fixed in 2.3.

See
https://github.com/zanata/zanata/commit/a31bf06f015c022d8f4dfe80ed624cd42e933fd9

Comment 2 David Mason 2013-04-23 04:03:08 UTC
(In reply to comment #1)
> Issue fixed in 2.3.
> 
> See
> https://github.com/zanata/zanata/commit/
> a31bf06f015c022d8f4dfe80ed624cd42e933fd9

Correction: see https://github.com/zanata/zanata/commit/76cc2a55875c9a27d45c51bc1e9c4d9028e32b9a

Comment 3 Ding-Yi Chen 2013-04-23 07:29:28 UTC
VERIFIED with Zanata version 2.3-SNAPSHOT (20130423-1233).

Comment 4 Sean Flanigan 2013-11-27 03:13:14 UTC
Closing VERIFIED bugs for Zanata versions <= 3.1.

Comment 5 Sean Flanigan 2013-11-27 03:15:20 UTC
Closing VERIFIED bugs for Zanata versions <= 3.1.

Comment 6 Sean Flanigan 2013-11-27 03:18:20 UTC
Closing VERIFIED bugs for Zanata versions <= 3.1.

Comment 7 Sean Flanigan 2013-11-27 03:23:12 UTC
Closing VERIFIED bugs for Zanata versions <= 3.1.

Comment 8 Sean Flanigan 2013-11-27 03:33:02 UTC
Closing VERIFIED bugs for Zanata versions <= 3.1.

Comment 9 Sean Flanigan 2013-11-27 03:35:16 UTC
Closing VERIFIED bugs for Zanata versions <= 3.1.


Note You need to log in before you can comment on or make changes to this bug.