Bug 951000 - xorg qxl drv does not honor initial resolution specified in xorg.conf
Summary: xorg qxl drv does not honor initial resolution specified in xorg.conf
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: xorg-x11-drv-qxl
Version: 6.4
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Alon Levy
QA Contact: Desktop QE
URL:
Whiteboard:
Keywords:
: 918297 921909 (view as bug list)
Depends On:
Blocks: 960058
TreeView+ depends on / blocked
 
Reported: 2013-04-11 10:27 UTC by Hans de Goede
Modified: 2018-12-03 18:39 UTC (History)
7 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2013-11-21 20:48:48 UTC


Attachments (Terms of Use)
xorg.conf (2.86 KB, application/octet-stream)
2013-04-11 10:27 UTC, Hans de Goede
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2013:1650 normal SHIPPED_LIVE xorg-x11-drv-qxl bug fix update 2013-11-20 21:53:23 UTC
Red Hat Knowledge Base (Solution) 46480 None None None Never

Description Hans de Goede 2013-04-11 10:27:32 UTC
Created attachment 734106 [details]
xorg.conf

When using multiple qxl devices + xinerama, or multiple qxl devices with each being a separate screen (*), the only way to set the resolution is through xorg.conf, but for resolutions higher then 1026x768 this fails with the following error in Xorg.conf:

[     8.480] (II) qxl(0): Not using mode "1280x1024@60Hz" (height too large for virtual size)

I'll attach an example xorg.conf for a setup with 3 qxl devices where each is mapped to a separate Screen, and each should come up with a resolution of 1280x1024, but instead comes up with 1024x768.

*) Having each card as a separate screen is useful for running old proprietary X applications which were designed for multi monitor setups at a time that that still meant 1 screen per monitor.

Comment 1 hmiles 2013-04-26 18:33:21 UTC
*** Bug 918297 has been marked as a duplicate of this bug. ***

Comment 5 Alon Levy 2013-08-27 16:39:38 UTC
*** Bug 921909 has been marked as a duplicate of this bug. ***

Comment 8 errata-xmlrpc 2013-11-21 20:48:48 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1650.html


Note You need to log in before you can comment on or make changes to this bug.