Bug 951109 - kwin crashes when KDE desktop gets maximized in VNC
kwin crashes when KDE desktop gets maximized in VNC
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: qt (Show other bugs)
19
ppc64 Linux
medium Severity high
: ---
: ---
Assigned To: Daniel Vrátil
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F19PPCBeta/F19PPCBetaBlocker/PPCBetaBlocker
  Show dependency treegraph
 
Reported: 2013-04-11 09:44 EDT by Karsten Hopp
Modified: 2015-11-01 20:37 EST (History)
12 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-06-20 09:35:54 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
kcrash file (7.07 KB, text/plain)
2013-04-11 09:44 EDT, Karsten Hopp
no flags Details

  None (edit)
Description Karsten Hopp 2013-04-11 09:44:54 EDT
Created attachment 734209 [details]
kcrash file

Description of problem:
I was running KDE on a PPC64 machine in a vncserver. When I maximized the vncviewer window on my local machine, kwin crashed with the attached backtrace

Version-Release number of selected component (if applicable):
kde-workspace-4.10.1-2.fc19
Comment 1 Rex Dieter 2013-04-11 10:05:06 EDT
Hrm, after looking at bug #951103 , I see that these both died in the same lll_futex_wait function.  Here,

Application: KWin (kwin), signal: Segmentation fault
Using host libthread_db library "/lib64/libthread_db.so.1".
155	      lll_futex_wait (&cond->__data.__futex, futex_val, pshared);
[Current thread is 1 (Thread 0x3fff8cd3c290 (LWP 8166))]
Comment 2 Kevin Kofler 2013-04-11 11:25:46 EDT
When looking at a crash of a multithreaded program, the first thing to do is to identify the active thread, usually the only relevant one. Any thread stuck in something like lll_futex_wait, __lll_lock_wait etc. is NOT active. (Sadly, the wrong thread is current in GDB for some reason.)

This one is crashing in QCoreApplicationPrivate::sendPostedEvents, maybe a Qt bug?
Comment 3 Ngo Than 2013-05-22 12:25:58 EDT
it's crashed in libkscreen.so, Dan you can ask karsten to get account on ppc.
Comment 4 Daniel Vrátil 2013-05-24 12:59:05 EDT
Assigning back to kde-workspace. This is definitely not a KScreen crash :-) 
Anyway, can you please try to reproduce the crash with this Qt build?

http://ppc.koji.fedoraproject.org/scratch/dvratil/task_1128748/

It has a patch [0] that should solve crashes when using DBus from multiple threads.


[0] https://codereview.qt-project.org/#change,55874
Comment 5 Ngo Than 2013-05-28 11:35:13 EDT
Karsten cannot reproduce the crash aynmore with new qt update. reassign to correct qt component. I'm building new qt and will add it to f19 update today

Dan, good catch! thanks
Comment 6 Fedora Update System 2013-05-28 11:38:05 EDT
qt-4.8.4-18.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/qt-4.8.4-18.fc19
Comment 7 Fedora Update System 2013-05-29 13:43:51 EDT
Package qt-4.8.4-18.fc19:
* should fix your issue,
* was pushed to the Fedora 19 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing qt-4.8.4-18.fc19'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-9546/qt-4.8.4-18.fc19
then log in and leave karma (feedback).
Comment 8 Fedora Update System 2013-05-30 16:03:48 EDT
qt-4.8.4-19.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/qt-4.8.4-19.fc19
Comment 9 Ngo Than 2013-06-20 09:35:54 EDT
it doesn't crash after update to latest version

Note You need to log in before you can comment on or make changes to this bug.