Bug 951259 - traceback when trying to resolve block device spec from kickstart
Summary: traceback when trying to resolve block device spec from kickstart
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda
Version: 19
Hardware: Unspecified
OS: Linux
unspecified
unspecified
Target Milestone: ---
Assignee: David Lehman
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 952348 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-04-11 20:51 UTC by Shawn Starr
Modified: 2013-04-27 17:50 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2013-04-19 05:49:18 UTC


Attachments (Terms of Use)
Anaconda traceback (14.26 KB, image/png)
2013-04-11 20:51 UTC, Shawn Starr
no flags Details

Description Shawn Starr 2013-04-11 20:51:03 UTC
Created attachment 734416 [details]
Anaconda traceback

Description of problem:
Anaconda crashes parsing kickstart file when there's no devices listed to install from.

Version-Release number of selected component (if applicable):
19.17-1

How reproducible: Always


Steps to Reproduce:
1. Use this kickstart file: http://mkrizek.fedorapeople.org/default.ks
2. Boot a KVM w/o a CDROM device
3. Anaconda crashes on startup of parsing kickstart file.
  
Actual results:
Fails

Expected results:
Tries another install type by asking you

Comment 1 Shawn Starr 2013-04-11 20:58:27 UTC
This isn't install type that fails, but parsing the list of available devices to install/partition

Comment 2 David Lehman 2013-04-11 21:06:25 UTC
Anything in ks.cfg that triggers a call to deviceMatches (clearpart --drives=..., ignoredisk) will hit this traceback.

Comment 3 Shawn Starr 2013-04-13 06:35:01 UTC
Reproduced in TC6

Anaconda 19.18-1, waiting for patch to be reviewed/commited

Comment 4 David Lehman 2013-04-15 19:22:12 UTC
*** Bug 952348 has been marked as a duplicate of this bug. ***

Comment 5 Fedora Update System 2013-04-15 21:02:08 UTC
python-blivet-0.11-1.fc19,anaconda-19.19-1.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/python-blivet-0.11-1.fc19,anaconda-19.19-1.fc19

Comment 6 Fedora Update System 2013-04-16 16:11:25 UTC
Package python-blivet-0.11-1.fc19, anaconda-19.19-1.fc19, lorax-19.2-1.fc19:
* should fix your issue,
* was pushed to the Fedora 19 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing python-blivet-0.11-1.fc19 anaconda-19.19-1.fc19 lorax-19.2-1.fc19'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-5795/lorax-19.2-1.fc19,python-blivet-0.11-1.fc19,anaconda-19.19-1.fc19
then log in and leave karma (feedback).

Comment 7 Dean Hunter 2013-04-16 21:22:30 UTC
When will this update be part of a Fedora 19 ISO? I am using an ISO to build a VM when I encounter this problem.

Comment 8 Fedora Update System 2013-04-17 16:27:56 UTC
Package python-blivet-0.11-1.fc19, lorax-19.2-1.fc19, anaconda-19.20-1.fc19:
* should fix your issue,
* was pushed to the Fedora 19 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing python-blivet-0.11-1.fc19 lorax-19.2-1.fc19 anaconda-19.20-1.fc19'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-5795/lorax-19.2-1.fc19,python-blivet-0.11-1.fc19,anaconda-19.20-1.fc19
then log in and leave karma (feedback).

Comment 9 Fedora Update System 2013-04-19 05:49:20 UTC
python-blivet-0.11-1.fc19, lorax-19.2-1.fc19, anaconda-19.20-1.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 10 Dean Hunter 2013-04-26 20:08:05 UTC
Is this fix supposed to be in the Fedora 19 Alpha DVD ISO?

I downloaded and tried to build a virtual machine using the alpha DVD and still get this error.

Comment 11 Dean Hunter 2013-04-27 16:53:58 UTC
After further review the Fedora 19 alpha DVD ISO contains:

anaconda-19.20-1.fc19.x86_64
pykickstart-1.99.26-1.fc19.noarch
python-blivet-0.11-1.fc19.noarch

but I can not find lorax*. Where is it supposed to be?

Comment 12 Dean Hunter 2013-04-27 17:50:19 UTC
I apologize. My problem was due to operator error.


Note You need to log in before you can comment on or make changes to this bug.