Bug 9513 - error in spec file causes postinstall script to be missing
error in spec file causes postinstall script to be missing
Status: CLOSED RAWHIDE
Product: Red Hat Raw Hide
Classification: Retired
Component: bind (Show other bugs)
1.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Bernhard Rosenkraenzer
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-02-17 00:27 EST by Benjamin S. Scarlet
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-02-18 08:14:45 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Benjamin S. Scarlet 2000-02-17 00:27:02 EST
There is an error in the spec file in bind-8.2.2_P5-7.src.rpm, which
causes the associated binary rpms to be generated without the
postinstall script.  The error is just an erroneous leading space
before the "%post".  Unified diff follows.  Without this fix, the
package will not work unless there is already a user and group "named",
because they will not be created.

	Ben Scarlet
	scarlet@mit.edu

------------------CUT HERE----------------------
--- bind.spec	Thu Feb 17 00:18:47 2000
+++ bind.spec.old	Sat Feb 12 12:46:07 2000
@@ -109,7 +109,7 @@
 mkdir -p ${RPM_BUILD_ROOT}/etc/logrotate.d
 install -c -m 644 %SOURCE4 $RPM_BUILD_ROOT/etc/logrotate.d/named

-%post
+ %post
 /usr/sbin/useradd -c "Named" -u 25 \
 	-s /bin/false -r -d /var/named named 2>/dev/null || :
Comment 1 Bernhard Rosenkraenzer 2000-02-18 08:14:59 EST
Fixed in 8.8.2_P5-8

Note You need to log in before you can comment on or make changes to this bug.