Bug 951449 - error: qxl too old when booting F19 Alpha RC2
Summary: error: qxl too old when booting F19 Alpha RC2
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-qxl
Version: 19
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Alon Levy
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-04-12 09:29 UTC by Lukas Brabec
Modified: 2014-08-04 22:10 UTC (History)
10 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-02-25 16:36:56 UTC
Type: Bug


Attachments (Terms of Use)
Xorg log file (93.11 KB, text/x-log)
2013-04-12 10:49 UTC, Lukas Brabec
no flags Details

Description Lukas Brabec 2013-04-12 09:29:29 UTC
Description of problem:
Firstboot of Fedora 19 Alpha RC2 (xfce spin) is shown correctly, but after confirmation error is shown (and X won't start):
[drm:qxl_pci_probe] *ERROR* qxl too old, doesn't support client_monitors_config, use xf86-video-qxl in user mode

Steps to Reproduce:
1. Boot Fedora 19 Alpha RC2 XFCE
2. Do the default installation
3. Reboot

Comment 1 Hans de Goede 2013-04-12 09:39:57 UTC
Hi Lukas,

Thanks for the bug report. The error in dmesg is normal when using F-19 on a non F-19 host. the kms driver needs some features only available in F-19 qemu / spice.

But after that X should start normally using the user space qxl driver.

Can you collect Xorg.0.log and attach it here please?

Regards,

Hans

Comment 2 Lukas Brabec 2013-04-12 10:49:33 UTC
Created attachment 734653 [details]
Xorg log file

Comment 3 Hans de Goede 2013-04-12 11:35:48 UTC
(In reply to comment #2)
> Created attachment 734653 [details]
> Xorg log file

Hmm,

Nothing really interesting there. Do you perhaps get a segfault logged to dmesg ?

Comment 4 Lukas Brabec 2013-04-12 12:10:44 UTC
Maybe this will be helpful, found in /var/log/messages:

[2.907262] qxl: probe of 0000:00:02.0 failed with error -22

Comment 5 Jan Sedlák 2013-04-19 10:28:34 UTC
It's also happening in F19 Alpha RC4, XFCE after installation. After switching to VGA in virt-manager, it works. I got a lot "qxl_surface_create: Bad bpp: 1" in Xorg log.

Comment 6 Frank Büttner 2013-12-08 09:49:49 UTC
I have the same problem.
But running the release version of F19 under F19.

dmesg:
[    0.537334] [drm:qxl_pci_probe] *ERROR* qxl too old, doesn't support client_monitors_config, use xf86-video-qxl in user mode
 [    0.537573] qxl: probe of 0000:00:02.0 failed with error -22

Comment 7 Alon Levy 2013-12-08 09:57:06 UTC
A workaround is to start with "nomodeset" in the kernel command line, which forces no loading of qxl.ko, which in turn means the old user space only driver will be used by Xorg.

Comment 8 Frank Büttner 2013-12-08 11:08:13 UTC
As an additional hint, in my case the system don't run Xorg. It only runs in console mode, because X is not needed her.

Comment 9 Cole Robinson 2013-12-17 23:25:40 UTC
As mentioned in Comment #1, the error message is normal in certain cases but shouldn't cause any problems. Frank, it sounds like you are saying your VM isn't even using an x server, so the error messages are harmless.

Is anyone still seeing x server crashes or failures with an up to date F19? If so, please also try the qxl update here:

https://admin.fedoraproject.org/updates/FEDORA-2013-23510/xorg-x11-drv-qxl-0.1.1-3.fc19?_csrf_token=e1fb301f08a989fbf5d856fa42f559d5fdf207b5

And report back.

Comment 10 Cole Robinson 2014-02-25 16:36:56 UTC
I assume this is fixed with the latest f19 update, so closing.


Note You need to log in before you can comment on or make changes to this bug.