Bug 951495 - Maximum Disk Size system setting in gnome-boxes must be a multiple of 512 bytes
Summary: Maximum Disk Size system setting in gnome-boxes must be a multiple of 512 bytes
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: libvirt
Version: 19
Hardware: x86_64
OS: Linux
unspecified
medium
Target Milestone: ---
Assignee: Libvirt Maintainers
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 949591 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-04-12 10:26 UTC by Vera Budikova
Modified: 2013-06-29 18:45 UTC (History)
14 users (show)

Fixed In Version: libvirt-1.0.5.2-1.fc19
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2013-06-29 18:45:38 UTC
Type: Bug


Attachments (Terms of Use)
Troubleshooting log (7.73 KB, application/octet-stream)
2013-04-12 10:26 UTC, Vera Budikova
no flags Details

Description Vera Budikova 2013-04-12 10:26:41 UTC
Created attachment 734650 [details]
Troubleshooting log

Description of problem:
Problem with editing Maximum Disk Size system setting, because qemu-img requires that Maximum Disk Size system setting must be a multiple of 512 bytes.


Version-Release number of selected component (if applicable):
gnome-boxes-3.8.0-1.fc19.x86_64


How reproducible:
always


Steps to Reproduce:
1. New -> Continue -> Select a file
2. Customize -> System
3. Change Maximum Disk Size

or

1. Edit properties of existing VM -> System
2. Change Maximum Disk size

  
Actual results:

Maximum Disk Size is unchanged with the following warning:

(gnome-boxes:7480): Boxes-WARNING **: libvirt-machine-properties.vala:560: Failed to change storage capacity of volume 'ubuntu12.04' to 22291165305: Unable to resize volume storage: internal error Child process (/usr/bin/qemu-img resize /home/vbudikov/.local/share/gnome-boxes/images/ubuntu12.04 22291165305) unexpected exit status 1: qemu-img: The new size must be a multiple of 512
qemu-img: Error resizing image (22)


Expected results:
Maximum Disk Size is changed.


Additional info:

Comment 1 Daniel Berrangé 2013-04-12 10:34:33 UTC
libvirt is supposed to be rounding any sizes up to the nearest boundary required by tools it invokes. So Boxes ought not to need to deal with rounding itself.

Comment 2 Vera Budikova 2013-04-19 09:02:16 UTC
*** Bug 949591 has been marked as a duplicate of this bug. ***

Comment 4 Cole Robinson 2013-06-05 14:22:49 UTC
Moving to libvirt so I don't miss it when doing a build.

Comment 5 Fedora Update System 2013-06-12 22:08:03 UTC
libvirt-1.0.5.2-1.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/libvirt-1.0.5.2-1.fc19

Comment 6 Fedora Update System 2013-06-13 18:05:24 UTC
Package libvirt-1.0.5.2-1.fc19:
* should fix your issue,
* was pushed to the Fedora 19 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing libvirt-1.0.5.2-1.fc19'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-10769/libvirt-1.0.5.2-1.fc19
then log in and leave karma (feedback).

Comment 7 Fedora Update System 2013-06-29 18:45:38 UTC
libvirt-1.0.5.2-1.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.