Bug 951632 - Kickstart installation in text-mode doesn't run on s390x
Kickstart installation in text-mode doesn't run on s390x
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
19
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Samantha N. Bueno
Fedora Extras Quality Assurance
:
Depends On:
Blocks: ZedoraTracker 951094
  Show dependency treegraph
 
Reported: 2013-04-12 12:14 EDT by Dan Horák
Modified: 2013-08-23 09:48 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-08-23 09:48:43 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
anaconda.log (1.55 KB, text/x-log)
2013-04-12 12:15 EDT, Dan Horák
no flags Details
ifcfg.log (486 bytes, text/x-log)
2013-04-12 12:16 EDT, Dan Horák
no flags Details
packaging.log (12.67 KB, text/x-log)
2013-04-12 12:17 EDT, Dan Horák
no flags Details
program.log (39.53 KB, text/x-log)
2013-04-12 12:17 EDT, Dan Horák
no flags Details
storage.log (157.56 KB, text/x-log)
2013-04-12 12:18 EDT, Dan Horák
no flags Details
syslog (38.60 KB, application/octet-stream)
2013-04-12 12:18 EDT, Dan Horák
no flags Details
ps auxf (8.15 KB, application/octet-stream)
2013-04-12 12:19 EDT, Dan Horák
no flags Details

  None (edit)
Description Dan Horák 2013-04-12 12:14:42 EDT
Description of problem:
Kickstart installation in text-mode on s390x stops right after starting anaconda.

...
[ [32m  OK   [0m] Started System Logging Service.   
anaconda[1066]: Starting installer, one moment... 
anaconda[1066]: anaconda 19.18-1 for Fedora 20130412 (pre-release) started. 
anaconda[1066]: 16:13:50 Not asking for VNC because text mode was explicitly ask
ed for in kickstart 


Nothing else is happening, anaconda uses 100% of CPU.

Version-Release number of selected component (if applicable):
anaconda-19.18-1.fc19

How reproducible:
always

Steps to Reproduce:
1. start text-mode kickstart installation on s390x
  
Actual results:
Installation doesn't proceed

Expected results:
Installation finishes
Comment 1 Dan Horák 2013-04-12 12:15:55 EDT
Created attachment 734818 [details]
anaconda.log
Comment 2 Dan Horák 2013-04-12 12:16:34 EDT
Created attachment 734819 [details]
ifcfg.log
Comment 3 Dan Horák 2013-04-12 12:17:37 EDT
Created attachment 734820 [details]
packaging.log
Comment 4 Dan Horák 2013-04-12 12:17:56 EDT
Created attachment 734821 [details]
program.log
Comment 5 Dan Horák 2013-04-12 12:18:18 EDT
Created attachment 734822 [details]
storage.log
Comment 6 Dan Horák 2013-04-12 12:18:36 EDT
Created attachment 734823 [details]
syslog
Comment 7 Dan Horák 2013-04-12 12:19:02 EDT
Created attachment 734824 [details]
ps auxf
Comment 8 Dan Horák 2013-04-12 13:05:14 EDT
after attaching strace

...
access("/tmp/curl_fetch_url0/install.img", R_OK) = -1 ENOENT (No such file or directory)
access("/LiveOS/rootfs.img", R_OK)      = -1 ENOENT (No such file or directory)
access("/overlay", R_OK)                = -1 ENOENT (No such file or directory)
access("/tmp/curl_fetch_url0/install.img", R_OK) = -1 ENOENT (No such file or directory)
access("/LiveOS/rootfs.img", R_OK)      = -1 ENOENT (No such file or directory)
access("/overlay", R_OK)                = -1 ENOENT (No such file or directory)
access("/tmp/curl_fetch_url0/install.img", R_OK) = -1 ENOENT (No such file or directory)
access("/LiveOS/rootfs.img", R_OK)      = -1 ENOENT (No such file or directory)
access("/overlay", R_OK)                = -1 ENOENT (No such file or directory)
access("/tmp/curl_fetch_url0/install.img", R_OK) = -1 ENOENT (No such file or directory)
....
Comment 9 Dan Horák 2013-04-29 06:19:43 EDT
I don't see this issue with anaconda 19.21 (with http://fedoraproject.org/wiki/Architectures/s390x/19#issues_found_in_F-19_post-Alpha_20130424) anymore

Note You need to log in before you can comment on or make changes to this bug.