Bug 951806 - papi-5.1.0.2-1 is FTBFS on ARM
papi-5.1.0.2-1 is FTBFS on ARM
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: papi (Show other bugs)
19
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: William Cohen
Fedora Extras Quality Assurance
:
Depends On:
Blocks: ARMTracker
  Show dependency treegraph
 
Reported: 2013-04-13 05:30 EDT by Peter Robinson
Modified: 2013-06-08 23:32 EDT (History)
1 user (show)

See Also:
Fixed In Version: papi-5.1.0.2-2.fc19
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-06-08 23:32:20 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Peter Robinson 2013-04-13 05:30:11 EDT
Fails on F19/rawhide

http://arm.koji.fedoraproject.org/koji/taskinfo?taskID=1704319
Comment 1 William Cohen 2013-04-15 16:59:56 EDT
Tracked the problem down to the following upstream papi commit because it removes the mb() definition for arm:

commit 59d3d7584b2925bd05b4b5d0f4fe89666eb8494a
Author: Vince Weaver <vincent.weaver@maine.edu>
Date:   Thu Oct 18 15:24:29 2012 -0400

    Update the memory barriers
    
    It turns out PAPI fails on older 32-bit x86 machines because it tries
    to use an SSE rmb() memory barrier.
    
    (Yes, I'm trying to run PAPI on a Pentium II.  Don't ask)
    
    It looks like our memory barriers were copied out of the kernel, which
    doesn't quite work because it expects some kernel infrastructure
    instead.
    
    This patch uses the definitions used by the "perf" tool instead.
    
    Also dropped the use of the mb() memory barrier on mmap tail write,
    as the perf tool itself did a while ago so I'm hoping it's safe to do so
    as well.  It makes these definitions a lot simpler.
Comment 2 William Cohen 2013-04-16 09:14:30 EDT
Put a patch in the srpm rawhide and f19 srpms to address this problem.  The srpm should build on arm now.
Comment 3 Fedora Update System 2013-05-30 17:58:37 EDT
papi-5.1.0.2-2.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/papi-5.1.0.2-2.fc19
Comment 4 Fedora Update System 2013-05-31 14:08:34 EDT
Package papi-5.1.0.2-2.fc19:
* should fix your issue,
* was pushed to the Fedora 19 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing papi-5.1.0.2-2.fc19'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-9727/papi-5.1.0.2-2.fc19
then log in and leave karma (feedback).
Comment 5 Fedora Update System 2013-06-08 23:32:20 EDT
papi-5.1.0.2-2.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.