Bug 951826 - inet_protocols default setting and man page do not match
inet_protocols default setting and man page do not match
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: man-pages-overrides (Show other bugs)
6.3
All Linux
unspecified Severity low
: rc
: ---
Assigned To: Peter Schiffer
Iveta Wiedermann
: EasyFix, ManPageChange, Patch
Depends On:
Blocks: 1011215
  Show dependency treegraph
 
Reported: 2013-04-13 09:46 EDT by Chris Gardner
Modified: 2013-11-21 17:56 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Cause: default configuration of postfix server documented on postconf(5) man page was incorrect Consequence: incorrect documentation Fix: describe correct default documentation of postfix server on postconf(5) man page Result: correct documentation
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-11-21 17:56:35 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
postconf.5.patch (600 bytes, patch)
2013-09-20 08:20 EDT, Peter Schiffer
no flags Details | Diff

  None (edit)
Description Chris Gardner 2013-04-13 09:46:48 EDT
Description of problem:
The parameter "inet_protocols" has a different default value than documented.
The Man page postconf(5) says "inet_protocols = ipv4" but /etc/postfix/main.conf contains "inet_protocols = all".

Version-Release number of selected component (if applicable):
postfix-2.6.6-2.2.el6_1.x86_64

How reproducible:
100%

Steps to Reproduce:
1. man 5 postconf |grep inet_protocols
2. grep inet_protocols /etc/postfix/main.cf
  
Actual results:
Man page and actual default setting do not match.

Expected results:
Man page and actual default setting are the same.

Additional info:
Either the man page or the default setting needs to be changed.

This probably affects Fedora too as suggested by bug #863140.
Comment 2 Peter Schiffer 2013-09-20 08:20:38 EDT
Created attachment 800476 [details]
postconf.5.patch
Comment 8 errata-xmlrpc 2013-11-21 17:56:35 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1695.html

Note You need to log in before you can comment on or make changes to this bug.