Bug 952139 - Nagios notifications contains "+" signs instead of spaces.
Summary: Nagios notifications contains "+" signs instead of spaces.
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: nagios
Version: 18
Hardware: Unspecified
OS: Linux
unspecified
unspecified
Target Milestone: ---
Assignee: Keiran Smith
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: 926958
TreeView+ depends on / blocked
 
Reported: 2013-04-15 09:39 UTC by Jan ONDREJ
Modified: 2013-05-03 01:55 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2013-05-02 04:35:05 UTC


Attachments (Terms of Use)

Description Jan ONDREJ 2013-04-15 09:39:42 UTC
Description of problem:
Nagios notifications contains "+" signs instead of spaces. Also special non-ascii characters are replaced by "+".

Version-Release number of selected component (if applicable):
nagios-3.4.4-1.fc18.x86_64

How reproducible:
always

Steps to Reproduce:
1. wait for a nagios report
2. check email's content, specially the Date/Time field
  
Actual results:
Date/Time: Mon+Apr+15+11:32:10+CEST+2013

Expected results:
Date/Time: Mon Apr 15 11:32:10 CEST 2013

Additional info:
A patch is available upstream:
http://tracker.nagios.org/file_download.php?file_id=163&type=bug

Upstream bug:
http://tracker.nagios.org/view.php?id=407

Looks like upgrade to 3.5.0 does not fix this, so please update also after updating to this version.

Comment 1 Jose Pedro Oliveira 2013-04-20 08:22:00 UTC
Jan,

Could you test this release?

 * nagios-3.5.0-2.fc20
   http://koji.fedoraproject.org/koji/buildinfo?buildID=413135

tia,
jpo

Comment 2 Jan ONDREJ 2013-04-20 17:32:04 UTC
Thanks for build. I can confirm all problems from this bug fixed in this build. Please build it for f18 too. Thanks.

Comment 3 Fedora Update System 2013-04-20 18:00:59 UTC
nagios-3.5.0-2.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/nagios-3.5.0-2.fc19

Comment 4 Fedora Update System 2013-04-20 18:01:42 UTC
nagios-3.5.0-2.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/nagios-3.5.0-2.fc18

Comment 5 Fedora Update System 2013-04-21 03:25:36 UTC
Package nagios-3.5.0-2.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing nagios-3.5.0-2.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-6175/nagios-3.5.0-2.fc18
then log in and leave karma (feedback).

Comment 6 Fedora Update System 2013-04-24 00:46:37 UTC
nagios-3.5.0-3.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/nagios-3.5.0-3.fc19

Comment 7 Fedora Update System 2013-04-24 00:47:50 UTC
nagios-3.5.0-3.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/nagios-3.5.0-3.fc18

Comment 8 Jose Pedro Oliveira 2013-05-01 23:41:14 UTC
Problem has been fixed upstream (commit 2751):

 * http://nagios.svn.sourceforge.net/viewvc/nagios?view=revision&revision=2751

Comment 9 Fedora Update System 2013-05-02 04:35:07 UTC
nagios-3.5.0-3.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 10 Fedora Update System 2013-05-03 01:55:51 UTC
nagios-3.5.0-3.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.