Bug 952351 - Review Request: ovirt-iso-uploader - ISO Uploader tool for oVirt Engine
Review Request: ovirt-iso-uploader - ISO Uploader tool for oVirt Engine
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: Package Review (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Nobody's working on this, feel free to take it
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-04-15 14:39 EDT by Kiril Nesenko
Modified: 2014-07-10 20:09 EDT (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-07-02 02:29:16 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Kiril Nesenko 2013-04-15 14:39:18 EDT
Spec URL: http://knesenko.fedorapeople.org/ovirt-iso-uploader.spec
SRPM URL: http://knesenko.fedorapeople.org/ovirt-iso-uploader-3.2.1-1.fc17.src.rpm
Description: ISO Uploader tool for oVirt Engine
Fedora Account System Username: knesenko
Comment 1 Kiril Nesenko 2013-04-16 09:32:47 EDT
Koji build: http://koji.fedoraproject.org/koji/taskinfo?taskID=5258192
Comment 2 Kiril Nesenko 2013-04-17 10:09:19 EDT
Spec URL: http://knesenko.fedorapeople.org/ovirt-iso-uploader.spec
SRPM URL: http://knesenko.fedorapeople.org/ovirt-iso-uploader-3.2.2-1.fc17.src.rpm
Description: ISO Uploader tool for oVirt Engine
Fedora Account System Username: knesenko
Comment 3 Fabian Affolter 2013-04-21 10:56:33 EDT
Just some quick comments:

- There is no license statement needed in the spec file.
- 'package_version' and 'package_name' are not really needed. They only duplicate %{name} and {version}.
- 'BuildRoot:' and 'rm -rf "%{buildroot}"' are obsolete for latest Fedora and RHEL releases.
- '%{?release_suffix}' seems to be a leftover.
- The timestamps are not preserved in the %install section. Never seen the use of parallel make in the %install section either.
  (e.g. make install DESTDIR=%{buildroot} INSTALL="install -p")

The package is named 'ovirt-iso-uploader', the binary 'engine-iso-uploader', the manpage 'engine-iso-uploader.8.gz', and the configuration file 'isouploader.conf'. From my point of view a more consistent naming schema would make it easier for user to identify the components which belong together.
Comment 4 Vasant Hegde 2013-04-30 00:49:25 EDT
Package Review
==============

Key:
[x] = Pass
[!] = Fail
[-] = Not applicable
[?] = Not evaluated
[ ] = Manual review needed



===== MUST items =====

Generic:
[ ]: Package is licensed with an open-source compatible license and meets
     other legal requirements as defined in the legal section of Packaging
     Guidelines.
[ ]: Package contains no bundled libraries without FPC exception.
[ ]: Changelog in prescribed format.
[ ]: Sources contain only permissible code or content.
[ ]: Package contains desktop file if it is a GUI application.
[ ]: Development files must be in a -devel package
[ ]: Package requires other packages for directories it uses.
[ ]: Package uses nothing in %doc for runtime.
[ ]: Package is not known to require ExcludeArch.
[ ]: Package complies to the Packaging Guidelines
[ ]: License field in the package spec file matches the actual license.
     Note: Checking patched sources after %prep for licenses. Licenses found:
     "Apache (v2.0)", "GPL", "LGPL (v2.1 or later)", "LGPL", "Unknown or
     generated". 5 files have unknown license. Detailed output of licensecheck
     in /data/opensource/powerpack/git/fedora-scm/952351/review-ovirt-iso-
     uploader/licensecheck.txt
[ ]: Package consistently uses macro is (instead of hard-coded directory
     names).
[ ]: Package is named according to the Package Naming Guidelines.
[ ]: Package does not generate any conflict.
[ ]: Package obeys FHS, except libexecdir and /usr/target.
[ ]: If the package is a rename of another package, proper Obsoletes and
     Provides are present.
[ ]: Package must own all directories that it creates.
[ ]: Package does not own files or directories owned by other packages.
[ ]: Requires correct, justified where necessary.
[ ]: Spec file is legible and written in American English.
[ ]: Package contains systemd file(s) if in need.
[ ]: Large documentation must go in a -doc subpackage.
     Note: Documentation size is 20480 bytes in 2 files.
[x]: All build dependencies are listed in BuildRequires, except for any that
     are listed in the exceptions section of Packaging Guidelines.
[x]: Package does not run rm -rf %{buildroot} (or $RPM_BUILD_ROOT) at the
     beginning of %install.
[x]: %config files are marked noreplace or the reason is justified.
[x]: Each %files section contains %defattr if rpm < 4.4
[x]: Macros in Summary, %description expandable at SRPM build time.
[x]: Package does not contain duplicates in %files.
[x]: Permissions on files are set properly.
[x]: Fully versioned dependency in subpackages, if present.
[x]: Spec file lacks Packager, Vendor, PreReq tags.
[x]: If (and only if) the source package includes the text of the license(s)
     in its own file, then that file, containing the text of the license(s)
     for the package is included in %doc.
[x]: Package use %makeinstall only when make install' ' DESTDIR=... doesn't
     work.
[x]: Package is named using only allowed ASCII characters.
[x]: No %config files under /usr.
[x]: Package do not use a name that already exist
[x]: Package is not relocatable.
[x]: Sources used to build the package match the upstream source, as provided
     in the spec URL.
[x]: Spec file name must match the spec package %{name}, in the format
     %{name}.spec.
[x]: File names are valid UTF-8.
[x]: Packages must not store files under /srv, /opt or /usr/local
[x]: Package successfully compiles and builds into binary rpms on at least one
     supported primary architecture.
[x]: Package installs properly.
[x]: Rpmlint is run on all rpms the build produces.
     Note: No rpmlint messages.

Python:
[ ]: Python eggs must not download any dependencies during the build process.
[ ]: A package which is used by another package via an egg interface should
     provide egg info.
[ ]: Package meets the Packaging Guidelines::Python
[x]: Package contains BR: python2-devel or python3-devel
[x]: Binary eggs must be removed in %prep

===== SHOULD items =====

Generic:
[!]: Buildroot is not present
     Note: Invalid buildroot found: %{_tmppath}/%{name}-%{version}-%{release}
[ ]: If the source package does not include license text(s) as a separate file
     from upstream, the packager SHOULD query upstream to include it.
[ ]: Final provides and requires are sane (see attachments).
[ ]: Package functions as described.
[ ]: Latest version is packaged.
[ ]: Package does not include license text files separate from upstream.
[ ]: Description and summary sections in the package spec file contains
     translations for supported Non-English languages, if available.
[ ]: Package should compile and build into binary rpms on all supported
     architectures.
[ ]: %check is present and all tests pass.
[ ]: Packages should try to preserve timestamps of original installed files.
[x]: Sources can be downloaded from URI in Source: tag
[x]: Reviewer should test that the package builds in mock.
[x]: Package has no %clean section with rm -rf %{buildroot} (or
     $RPM_BUILD_ROOT)
[x]: Dist tag is present.
[x]: No file requires outside of /etc, /bin, /sbin, /usr/bin, /usr/sbin.
[x]: Uses parallel make.
[x]: SourceX tarball generation or download is documented.
[x]: SourceX is a working URL.
[x]: Spec use %global instead of %define.

===== EXTRA items =====

Generic:
[x]: Large data in /usr/share should live in a noarch subpackage if package is
     arched.
[x]: Rpmlint is run on all installed packages.
     Note: No rpmlint messages.
[x]: Spec file according to URL is the same as in SRPM.


Rpmlint
-------
Checking: ovirt-iso-uploader-3.2.2-1.fc17.noarch.rpm
1 packages and 0 specfiles checked; 0 errors, 0 warnings.




Rpmlint (installed packages)
----------------------------
# rpmlint ovirt-iso-uploader
1 packages and 0 specfiles checked; 0 errors, 0 warnings.
# echo 'rpmlint-done:'



Requires
--------
ovirt-iso-uploader (rpmlib, GLIBC filtered):
    /usr/bin/python
    config(ovirt-iso-uploader)
    ovirt-engine-sdk
    python
    python(abi)



Provides
--------
ovirt-iso-uploader:
    config(ovirt-iso-uploader)
    ovirt-iso-uploader



MD5-sum check
-------------
http://resources.ovirt.org/releases/3.2/src/ovirt-iso-uploader-3.2.2.tar.gz :
  CHECKSUM(SHA256) this package     : 347ae601e6efa3be551e76a580c2bd099b0e119014f1f62d74078e210a9665dc
  CHECKSUM(SHA256) upstream package : 347ae601e6efa3be551e76a580c2bd099b0e119014f1f62d74078e210a9665dc


Generated by fedora-review 0.4.0 (660ce56) last change: 2013-01-29
Buildroot used: fedora-17-x86_64
Command line :/usr/bin/fedora-review -n ovirt-iso-uploader
Comment 5 Vasant Hegde 2013-04-30 01:26:18 EDT
(In reply to comment #3)
> Just some quick comments:
> 
> - There is no license statement needed in the spec file.
> - 'package_version' and 'package_name' are not really needed. They only
> duplicate %{name} and {version}.
> - 'BuildRoot:' and 'rm -rf "%{buildroot}"' are obsolete for latest Fedora
> and RHEL releases.
> - '%{?release_suffix}' seems to be a leftover.
> - The timestamps are not preserved in the %install section. Never seen the
> use of parallel make in the %install section either.
>   (e.g. make install DESTDIR=%{buildroot} INSTALL="install -p")
> 
> The package is named 'ovirt-iso-uploader', the binary 'engine-iso-uploader',
> the manpage 'engine-iso-uploader.8.gz', and the configuration file
> 'isouploader.conf'. From my point of view a more consistent naming schema
> would make it easier for user to identify the components which belong
> together.

.. Also

%changelog
	Requires better description of changes

-Vasant
Comment 6 Karsten Hopp 2013-04-30 06:18:42 EDT
most files in the intl directory are GPLv2+, this isn't mentioned in the spec file. According to 
https://fedoraproject.org/wiki/Licensing:Main?rd=Licensing#Software_License_List

ASL-2.0 is not compatible with GPLv2, so those files in this usecase are either GPL3 or the mustn't be linked with the other ovirt-iso files.
Comment 7 Karsten Hopp 2013-04-30 07:28:57 EDT
[!]: Package must own all directories that it creates.
  doesn't own directory /usr/lib/python2.7/site-packages/ovirt_iso_uploader
[!]: Package does not run rm -rf %{buildroot} (or $RPM_BUILD_ROOT) at the
     beginning of %install.
Comment 8 Fabian Affolter 2013-06-27 15:14:25 EDT
Kiril, can you please provide an updated spec file and an SRPM. Thanks.
Comment 9 Christopher Meng 2013-09-05 10:09:11 EDT
Why WONTFIX?

Note You need to log in before you can comment on or make changes to this bug.