Bug 952773 - abrt throttling not working
Summary: abrt throttling not working
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: abrt
Version: 6.3
Hardware: Unspecified
OS: Linux
medium
high
Target Milestone: rc
: ---
Assignee: abrt
QA Contact: Lukas Zachar
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-04-16 16:30 UTC by Harold Miller
Modified: 2018-12-01 15:42 UTC (History)
5 users (show)

Fixed In Version: abrt-2.0.8-18.el6
Doc Type: Bug Fix
Doc Text:
Cause: abrt-watch-log and abrt-dump-oops are creating too many new problem directories when kernel error occurs periodically. Consequence: User is flooded with problem reports. Possibly overflowing /var partititon. Fix: abrt-dump-oops is changed to ignore all additional problems for a few minutes after it sees 5 or more of them. Result: User is not flooded with problem reports.
Clone Of:
Environment:
Last Closed: 2013-11-21 09:31:05 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2013:1586 normal SHIPPED_LIVE abrt, libreport and btparser bug fix and enhancement update 2013-11-20 21:39:37 UTC

Description Harold Miller 2013-04-16 16:30:59 UTC
Description of problem:Customer ha d real error (soft-lockup) and abrt generated 8600 folders and 600+ emails to root@. There ought to be a time limit between creating crashes and a crash de-duplication mechanism - seems these are not working,

Version-Release number of selected component (if applicable):


How reproducible: 


Steps to Reproduce:
1.
2.
3.
  
Actual results: Many folders and emails created


Expected results: a more reasonable number of folders and emails, or a configuration option to allow us to select reports/10min


Additional info:

Comment 1 Martin Milata 2013-04-16 16:44:49 UTC
Based on an irc communication, it appears that this problem applies to kerneloops hook. Do our time-limiting & local deduplication mechanisms work with kerneloops problems?

Comment 3 Jakub Filak 2013-04-17 07:58:36 UTC
(In reply to comment #1)

Seems that ABRT tries to limit the number of reported kerneloops problems.

Upstream commit:

commit 6fc121f145354dd95bb588eb685f1593f5156ca0
Author: Denys Vlasenko <dvlasenk@redhat.com>
Date:   Tue Feb 5 17:32:43 2013 +0100

    abrt-dump-{oops,xorg}: limit amount of created dirs, add cooldown sleep if exceeded
    
    Signed-off-by: Denys Vlasenko <dvlasenk@redhat.com>

Comment 4 Denys Vlasenko 2013-06-14 10:44:01 UTC
abrt git, rhel6 branch commit:

commit 39b2415c9138664300232735b6ab83b99e39e341
Author: Denys Vlasenko <dvlasenk@redhat.com>
Date:   Wed Jun 12 14:33:21 2013 +0200

    abrt-dump-oops: limit amount of created dirs, add cooldown sleep if exceeded. rhbz#952773

    This is a partial backport of 6fc121f145354dd95bb588eb685f1593f5156ca0.

    Signed-off-by: Denys Vlasenko <dvlasenk@redhat.com>
    Signed-off-by: Jiri Moskovcak <jmoskovc@redhat.com>

Comment 7 errata-xmlrpc 2013-11-21 09:31:05 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1586.html


Note You need to log in before you can comment on or make changes to this bug.