Bug 952778 - Unable to render combining accent with some characters under KDE
Summary: Unable to render combining accent with some characters under KDE
Keywords:
Status: CLOSED UPSTREAM
Alias: None
Product: Fedora
Classification: Fedora
Component: liberation-fonts
Version: 18
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Pravin Satpute
QA Contact: Fedora Extras Quality Assurance
URL: https://en.wikipedia.org/wiki/Stress_...
Whiteboard:
Depends On: 985373
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-04-16 16:42 UTC by Graeme Hewson
Modified: 2013-10-04 00:23 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2013-08-01 04:40:56 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
KDE Software Compilation 315642 None None None Never

Description Graeme Hewson 2013-04-16 16:42:07 UTC
In https://en.wikipedia.org/wiki/Stress_%28linguistics%29 the following strings occur:

«земли́ (genitive of "earth, land") vs. зе́мли (plural of "earth, land") in Russian»
«In Russian and Ukrainian dictionaries, stress is indicated with an acute accent (´) on a syllable's vowel (example: вимовля́ння)»

In all the native KDE/Qt applications I've tried, these combining acute accents display as empty rectangles. The problem only occurs with Liberation and Ubuntu fonts, and it doesn't occur with GTK-based applications such as Firefox when run on the same KDE platform. (I haven't tested Ubuntu fonts with Fedora as they're not installed by default.) It seems there's some combination of problems with these fonts and with KDE or Qt.

To reproduce the problem in Konqueror, display the above Wikipedia article then go to Settings / Configure Konqueror menu, then under Web Browsing, Appearance entry, Fonts tab. For Sans serif font, select Liberation (note the default is DejaVu); click OK or Apply. To reproduce while displaying bugzilla.redhat.com (e.g., this bug report!), change Fixed font instead.

I've created a small HTML file here: http://bugsfiles.kde.org/attachment.cgi?id=77513 which demonstrates the problem (not confined to Cyrillic characters), and also shows a couple of characters which display correctly. Change the Standard font in Konqueror to demonstrate the problem.

To reproduce the problem in Konsole, download the file and cat it. Go to Settings/Edit Current Profile, Appearance tab and click Select Font. Note it's not necessary to click Apply or OK after selecting the font; all instances of Konsole update their font dynamically as you select it.

I've reported the problem against KDE and Ubuntu fonts here:

https://bugs.kde.org/show_bug.cgi?id=315642
https://bugs.launchpad.net/ubuntu-font-family/+bug/1131890

Comment 1 Nicolas Mailhot 2013-04-17 07:57:12 UTC
While this is a problem that should be fixed, stress is by and large not indicated in written Russian/Ukrainian. The only books where it is explicitly stated are dictionaries and teaching materials for western students (for native speakers it is so natural it does not need indication).

So working diacritics on Cyrillic letters has about the same priority as working phonetic notation in Latin text.

Comment 2 Pravin Satpute 2013-07-17 11:04:47 UTC
Though i can add some of these stress marks in Liberation fonts. But root problem is from qt.

Qt is not able to select characters from fallback fonts when selected fonts does not have these characters.

This should be fixed in qt.

Comment 3 Denis Jacquerye 2013-07-26 13:03:18 UTC
(In reply to Nicolas Mailhot from comment #1)
> While this is a problem that should be fixed, stress is by and large not
> indicated in written Russian/Ukrainian. The only books where it is
> explicitly stated are dictionaries and teaching materials for western
> students (for native speakers it is so natural it does not need indication).
> 
> So working diacritics on Cyrillic letters has about the same priority as
> working phonetic notation in Latin text.

The Russian and Ukrainian and other Slavic language Wikipedias use the stress marks in a lot of articles on the first occurrence of an entry word.

Comment 4 Nicolas Mailhot 2013-07-27 10:35:26 UTC
(In reply to Denis Jacquerye from comment #3)
> (In reply to Nicolas Mailhot from comment #1)
> > While this is a problem that should be fixed, stress is by and large not
> > indicated in written Russian/Ukrainian. The only books where it is
> > explicitly stated are dictionaries and teaching materials for western
> > students (for native speakers it is so natural it does not need indication).
> > 
> > So working diacritics on Cyrillic letters has about the same priority as
> > working phonetic notation in Latin text.
> 
> The Russian and Ukrainian and other Slavic language Wikipedias use the
> stress marks in a lot of articles on the first occurrence of an entry word.

Right, they are giving the phonetics like a dictionnary

Comment 5 Graeme Hewson 2013-07-31 15:48:59 UTC
This was reported against Qt: https://bugreports.qt-project.org/browse/QTBUG-32470, and is apparently fixed in Qt 5.0.

If Qt 5.0 renders the characters the same way as GTK does currently, then I guess that's good enough (though obviously having the accent to the side on the capital letters and on ё isn't typographically ideal).

а́ е́ ё́ и́ о́ у́ ы́ э́ ю́ я́
А́ Е́ Ё́ И́ О́ У́ Ы́ Э́ Ю́ Я́

Is there any reason to keep this bug open?

Comment 6 Pravin Satpute 2013-08-01 04:40:56 UTC
Closing. Do reopen if any more issue with this.

Comment 7 Kevin Kofler 2013-08-02 09:51:36 UTC
> Is there any reason to keep this bug open?

Qt 4 is going to stay around for a long time to come. We still ship qt3 and a handful applications still use it.

Comment 8 Pravin Satpute 2013-08-05 06:46:00 UTC
Even though i am bit reluctant to add new shapes to Liberation 1.07 since we do have Liberation 2.0 which has much broader coverage than Liberation 1.07.

But as you might be knowing due to hinting compatibilities we are not packaging liberation 2.0 into Fedora.

I am just thinking for some alternatives so that, users preferring character coverage rather than fine hinting output will able to use liberation fonts 2.0

Comment 9 Red Hat Bugzilla 2013-10-04 00:23:06 UTC
Removing external tracker bug with the id '32470' as it is not valid for this tracker


Note You need to log in before you can comment on or make changes to this bug.