Bug 952855 - (CVE-2012-4067) CVE-2012-4067 eucalyptus: Insecure XML Parsing Vulnerability in Walrus
CVE-2012-4067 eucalyptus: Insecure XML Parsing Vulnerability in Walrus
Status: CLOSED NOTABUG
Product: Security Response
Classification: Other
Component: vulnerability (Show other bugs)
unspecified
Unspecified Unspecified
medium Severity medium
: ---
: ---
Assigned To: Red Hat Product Security
impact=moderate,public=20130416,repor...
: Security
Depends On: 953354
Blocks:
  Show dependency treegraph
 
Reported: 2013-04-16 17:21 EDT by Andy Grimm
Modified: 2016-11-07 22:47 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-04-17 22:44:04 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Eucalyptus JIRA EUCA-5277 None None None Never

  None (edit)
Description Andy Grimm 2013-04-16 17:21:30 EDT
Walrus was not securely parsing XML messages containing Document Type Declarations (DTDs). This flaw could be exploited by a remote unauthenticated
attacker to perform Denial of Service attacks against Walrus.

Links:
http://www.eucalyptus.com/eucalyptus-cloud/security/esa-09
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2012-4067
https://eucalyptus.atlassian.net/browse/EUCA-5277
Comment 1 David Jorm 2013-04-17 22:42:30 EDT
Statement:

Not affected. This flaw does not affect the jclouds Eucalyptus API as shipped with JBoss Fuse 6.0.0 and Fuse ESB Enterprise 7.1.0.
Comment 2 David Jorm 2013-04-17 22:43:31 EDT
Created eucalyptus tracking bugs for this issue

Affects: fedora-all [bug 953354]

Note You need to log in before you can comment on or make changes to this bug.