Bug 952948 - CLIENTS role in a guest recipe halts /distribution/install task of host machine.
Summary: CLIENTS role in a guest recipe halts /distribution/install task of host machine.
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Beaker
Classification: Community
Component: beah
Version: 0.12
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified vote
Target Milestone: 0.12.1
Assignee: Dan Callaghan
QA Contact:
URL:
Whiteboard: MultiHost
Keywords: Regression
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-04-17 04:03 UTC by Raymond Mancy
Modified: 2018-02-06 00:41 UTC (History)
9 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2013-04-23 05:05:19 UTC


Attachments (Terms of Use)

Description Raymond Mancy 2013-04-17 04:03:58 UTC
Description of problem:

Multihost recipesets with a guest recipes fail when using CLIENTS role for guest.

Version-Release number of selected component (if applicable):

0.12

How reproducible:

Always

Steps to Reproduce:
1. Create a Multihost job with a guest recipe and CLIENTS
2. 
3.
  
Actual results:

The host hangs at the end of /distribution/install

Expected results:

Job doesn't do this

Additional info:

This is because report_finish in rhts-test-runner.sh does

  rhts-sync-block -s CLIENTS SERVERS DRIVERS

The CLIENTS will be 'None' because the guest recipe does not have a system with an fqdn yet, it only gets this after it's own /distribution/install has run.

Comment 1 Dan Callaghan 2013-04-17 06:13:05 UTC
This is strictly a regression in 0.10, but really multi-host between hosts and guests has never worked right for various reasons, this is just yet another problem.

And just to be clear, using CLIENTS, SERVERS, or DRIVER as the role for a guest recipe will trigger this bug.

Comment 2 Dan Callaghan 2013-04-22 00:15:41 UTC
On Gerrit: http://gerrit.beaker-project.org/1893

Comment 6 Dan Callaghan 2013-04-23 05:05:19 UTC
Beaker 0.12.1 has been released.


Note You need to log in before you can comment on or make changes to this bug.