Bug 952968 - the data percent of thin snapshots is not same after doing discards.
Summary: the data percent of thin snapshots is not same after doing discards.
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: lvm2
Version: 7.0
Hardware: Unspecified
OS: Unspecified
medium
high
Target Milestone: rc
: ---
Assignee: LVM and device-mapper development team
QA Contact: cluster-qe@redhat.com
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-04-17 04:54 UTC by Xiaowei Li
Modified: 2021-09-08 20:35 UTC (History)
9 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-01-22 03:32:52 UTC
Target Upstream Version:


Attachments (Terms of Use)
test.log (11.99 KB, text/plain)
2013-04-17 04:59 UTC, Xiaowei Li
no flags Details

Description Xiaowei Li 2013-04-17 04:54:51 UTC
Description of problem:
the data percent of thin snapshots is not same after doing discards.


Version-Release number of selected component (if applicable):
lvm2-2.02.98-5.el7.x86_64
kernel-3.9.0-0.rc6.51.el7.x86_64

How reproducible:


Steps to Reproduce:
1. create multiple snapshots of the same origin thin LV
2. do fstrim on the snapshots
3. lvs
  
Actual results:
the data percent of the snapshots is not same.

[CMD][00:48:53][dhcp-13-131.nay.redhat.com]lvs tsvg -o+discards
STDOUT:
  LV     VG   Attr      LSize   Pool Origin Data%  Move Log Copy%  Convert Discards
  origin tsvg Vwi-aotz- 100.00m pool         67.94                         nopassdown
  pool   tsvg twi-a-tz- 500.00m              15.59                         nopassdown
  snap1  tsvg Vwi-a-tz- 100.00m pool origin   8.19                         nopassdown
  snap2  tsvg Vwi-a-tz- 100.00m pool origin   8.19                         nopassdown
  snap3  tsvg Vwi-a-tz- 100.00m pool origin   7.06                         nopassdown
  snap4  tsvg Vwi-aotz- 100.00m pool origin   6.31                         nopassdown
  snap5  tsvg Vwi-a-tz- 100.00m pool origin  65.38                         nopassdown
STDERR:
RETURN:0


Expected results:


Additional info:

Comment 2 Xiaowei Li 2013-04-17 04:59:42 UTC
Created attachment 736670 [details]
test.log

Comment 3 Xiaowei Li 2013-04-17 05:21:13 UTC
very slight difference, not sure if it's by design.


Note You need to log in before you can comment on or make changes to this bug.