Bug 9530 - boot-RHEA-1999:044.img hangs system during boot
boot-RHEA-1999:044.img hangs system during boot
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: installer (Show other bugs)
6.1
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Michael Fulbright
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-02-17 13:07 EST by Mark V. Dalton
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-02-18 09:40:37 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Mark V. Dalton 2000-02-17 13:07:54 EST
When booting from a diskette made from boot-RHEA-1999:044.img, the boot
process stalls at the point it says "Running /sbin/loader...".  The system
remains completely catatonic requiring either a hard reset or a
power-off/power-on cycle to break out of it.

I'd run into this on a Gateway E-4300 (Pentium III) which was a new
installation so I fell back to booting directly off the RedHat 6.1
Installation CD and was ultimately successful.

I downloaded the boot diskette image, again, this time to a different
system and make a new boot diskette from it.  Just yesterday, I tried
installing RedHat 6.1 using the new boot diskette on a completely different
platform (IBM PC 365) and got exactly the same symptom.  This time,
however, I figured out what was going on.  Since the CD-ROM drive on the
IBM PC 365 is a lot noisier than the Gateway's I noticed that the RedHat
6.1 Installation CD-ROM was accessed quite early into the boot process.  In
fact, it's accessed at the time the message "Running /sbin/loader..." is
typed out.

I've always had the installation media in its drive, ready to go, so it
never occurred to me to wait for the prompt for media source and then
insert the CD-ROM at the time of the prompt.  When I took the CD-ROM volume
out and waited for the prompt, then inserted the CD-ROM volume and selected
local CDROM for media source, the boot process then did what it was
supposed to do, prompt for the updates diskette, then (in this case) enter
the graphical installer.  The rest of the process proceeded without further
incident.

It appears the that diskette boot image is mounting and using the CD-ROM
file system way too early.  It should not be referencing the CD-ROM drive
at all until that media is actually selected for use.  The work-around is
to wait for the media prompt before inserting the CD-ROM volume.
Comment 1 Jay Turner 2000-02-18 09:09:59 EST
This is a known bug which results from a race condition.  It will be fixed in
the next errata that we release (if we need to release further errata that is
:-))

Note You need to log in before you can comment on or make changes to this bug.