Bug 953071 - Logic volume management GUI can not be opened in some of the operation systems
Summary: Logic volume management GUI can not be opened in some of the operation systems
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: system-config-lvm
Version: 6.4
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: rc
: ---
Assignee: Marek Grac
QA Contact: Cluster QE
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-04-17 09:49 UTC by caochuangxiang
Modified: 2018-12-03 18:43 UTC (History)
11 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2014-10-14 04:24:01 UTC


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2014:1403 normal SHIPPED_LIVE system-config-lvm bug fix update 2014-10-14 00:55:01 UTC

Description caochuangxiang 2013-04-17 09:49:48 UTC
Description of problem:
Logic volume management gui can not be opened in some of the operation systems .

Run "# system-config-lvm" and get this error:

 The program 'system-config-lvm' received an X Window System error.
 This probably reflects a bug in the program.
 The error was 'BadAlloc (insufficient resources for operation)'.
  (Details: serial 14835 error_code 11 request_code 53 minor_code 0)
  (Note to programmers: normally, X errors are reported asynchronously;
   that is, you will receive the error a while after causing it.
   To debug your program, run it with the --sync command line
   option to change this behavior. You can then get a meaningful
   backtrace from your debugger if you break on the gdk_x_error() function.)

and sometimes also with this error:
Traceback (most recent call last):
  File "/usr/sbin/system-config-lvm", line 170, in ?
    runFullGUI()
  File "/usr/sbin/system-config-lvm", line 155, in runFullGUI
    blvm = baselvm(glade_xml, app)
  File "/usr/sbin/system-config-lvm", line 105, in __init__
    self.volume_tab_view = Volume_Tab_View(glade_xml, self.lvmm, self.main_win)
  File "/usr/share/system-config-lvm/Volume_Tab_View.py", line 136, in __init__
    self.prepare_tree()
  File "/usr/share/system-config-lvm/Volume_Tab_View.py", line 226, in prepare_tree
    self.mirror_sync_progress.initiate()
  File "/usr/share/system-config-lvm/Volume_Tab_View.py", line 593, in initiate
    if self.crank():
  File "/usr/share/system-config-lvm/Volume_Tab_View.py", line 602, in crank
    self.forked_command.fork()
  File "/usr/share/system-config-lvm/execute.py", line 134, in fork
    os.write(self.fd_write_out, out)
OSError: [Errno 32] Broken pipe

it seems that when call a system-config-lvm command in the operation system , a value which is pixels/width is a little big , and the gtk can not draw the Cylinder of all the LVs . Then the issue occurs .

Version-Release number of selected component (if applicable):
system-config-lvm-1.1.5-13

How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

Comment 1 caochuangxiang 2013-04-17 09:51:51 UTC
I have made a patch for this issue , please review that , thanks .
...
---
 .../system-config-lvm/Volume_Tab_View.py |    2 ++
 1 files changed, 2 insertions(+), 0 deletions(-)

diff --git a/system-config-lvm/Volume_Tab_View.py b/system-config-lvm/Volume_Tab_View.py
index cc09abc..1c38760 100644
--- a/system-config-lvm/Volume_Tab_View.py
+++ b/system-config-lvm/Volume_Tab_View.py
@@ -543,6 +543,8 @@ class Volume_Tab_View:
   
   def on_best_fit(self, obj):
       if (self.try_not_best_fit == True):
+          if self.display_view.display != None:
+              self.display_view.display.respect_smallest_selectable_width(False)
           return
 
       self.on_resize_drawing_area(None, None)
-- 
1.7.6.5

Comment 3 Ed Ackerman 2013-10-27 13:52:03 UTC
This patch also works on the following - 
  system-config-lvm-1.1.12-15.el6.noarch

Manually added the two patch lines.

Comment 4 caochuangxiang 2013-10-30 02:32:58 UTC
I didn't see these two lines in system-config-lvm-1.1.12-15.el6.src.rpm, I am curious that did you add them in?

Comment 6 Ed Ackerman 2013-11-07 03:12:33 UTC
(In reply to caochuangxiang from comment #4)
> I didn't see these two lines in system-config-lvm-1.1.12-15.el6.src.rpm, I
> am curious that did you add them in?

Sorry I was imprecise, I added them to the .py on my system.

Comment 19 errata-xmlrpc 2014-10-14 04:24:01 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-1403.html

Comment 20 caochuangxiang 2014-10-15 02:21:30 UTC
OK, thank you for the update.


Note You need to log in before you can comment on or make changes to this bug.