Bug 953076 - Cant set bonding mode
Cant set bonding mode
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: NetworkManager (Show other bugs)
6.4
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Jirka Klimes
Desktop QE
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-04-17 06:02 EDT by Tomas Pelka
Modified: 2016-01-04 01:02 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-11-21 16:50:03 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
[PATCH] editor: save bonding mode (1.88 KB, patch)
2013-07-09 09:15 EDT, Jirka Klimes
no flags Details | Diff

  None (edit)
Description Tomas Pelka 2013-04-17 06:02:54 EDT
Description of problem:
I'm not able to set mode for bonding devices. Round-robin will stay even if I apply changes. ifcfg file do not contain mode option and /proc/net/bonding/bond0 contain:

Bonding Mode: load balancing (round-robin)

Version-Release number of selected component (if applicable):
NetworkManager-0.8.1-43.el6

How reproducible:
100%

Steps to Reproduce:
1.
2.
3.
  
Actual results:
bonding mode not changed

Expected results:
bonding mode should change according nm-editor changes

Additional info:
Comment 1 Jirka Klimes 2013-07-09 09:10:44 EDT
nm-connection-editor don't set the bonding mode and thus it is not saved to ifcfg file.
Comment 2 Jirka Klimes 2013-07-09 09:15:20 EDT
Created attachment 771014 [details]
[PATCH] editor: save bonding mode

RHEL6.5 patch for nm-connection-editor to save bonding mode. In addition only allow MII monitoring for "balance-tlb" and "balance-alb" modes.

The same patch should also be added to upstream.
Comment 3 Dan Williams 2013-07-09 12:38:40 EDT
Looks good to me, commit to both 6.5 and upstream, thanks!
Comment 4 Jirka Klimes 2013-07-10 05:31:09 EDT
(In reply to Dan Williams from comment #3)
> Looks good to me, commit to both 6.5 and upstream, thanks!

Dan, could you give devel_ack+, it seems I don't have the privs.
Comment 5 Pavel Šimerda (pavlix) 2013-07-11 05:37:41 EDT
Looks good.
Comment 10 errata-xmlrpc 2013-11-21 16:50:03 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1670.html

Note You need to log in before you can comment on or make changes to this bug.