Bug 953123 - can't set Cloned MAC Address for VLAN
Summary: can't set Cloned MAC Address for VLAN
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: NetworkManager
Version: 6.4
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Jirka Klimes
QA Contact: Desktop QE
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-04-17 12:12 UTC by Tomas Pelka
Modified: 2013-11-21 21:50 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2013-11-21 21:50:08 UTC
Target Upstream Version:


Attachments (Terms of Use)
[PATCH] editor: correcly save VLAN MAC address and MTU (2.02 KB, patch)
2013-07-11 14:50 UTC, Jirka Klimes
no flags Details | Diff


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2013:1670 0 normal SHIPPED_LIVE NetworkManager bug fix and enhancement update 2013-11-21 00:39:32 UTC

Description Tomas Pelka 2013-04-17 12:12:59 UTC
Description of problem:
Not able to set Cloned MAC Address for VLAN connection, filed goes empty after apply and reopen in nm-connection-manager. The Cloned MAC Address value does not write to ifcfg file as well. 

Version-Release number of selected component (if applicable):
NetworkManager-0.8.1-43.el6

How reproducible:
100%

Steps to Reproduce:
1. Create VLAN profile
2. try to set up Cloned MAC Address
3.
  
Actual results:
MAC will not save and change

Expected results:
should be saved and changed

Additional info:
cat /etc/sysconfig/network-scripts/ifcfg-VLAN_connection_1 
VLAN=yes
TYPE=Vlan
DEVICE=vlan100
PHYSDEV=eth1
VLAN_ID=100
REORDER_HDR=0
BOOTPROTO=none
IPADDR=192.168.122.177
PREFIX=24
DEFROUTE=yes
IPV4_FAILURE_FATAL=yes
IPV6INIT=no
NAME="VLAN connection 1"
UUID=87fc8fac-49a3-49f2-8fec-0c2820cabe1a
ONBOOT=yes

Comment 1 Jirka Klimes 2013-07-11 14:46:13 UTC
This is the problem in nm-connection-editor.
The "parent interface" combo box doesn't set active item when initialized. It causes Cloned MAC and MTU not being saved when "Parent interface" was not re-selected (touched).

Comment 2 Jirka Klimes 2013-07-11 14:50:48 UTC
Created attachment 772263 [details]
[PATCH] editor: correcly save VLAN MAC address and MTU

This patch for RHEL6 fixes the issue. It is based on an upstream commit, however the commit had to be edited a bit for RHEL 6.5.

Comment 7 errata-xmlrpc 2013-11-21 21:50:08 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1670.html


Note You need to log in before you can comment on or make changes to this bug.