Bug 953198 - Environment scripts not preserved on upgrade
Environment scripts not preserved on upgrade
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: environment-modules (Show other bugs)
6.4
All Unspecified
low Severity low
: rc
: ---
Assigned To: Jan Synacek
Hubert Kario
:
Depends On:
Blocks: 953199 976349
  Show dependency treegraph
 
Reported: 2013-04-17 11:32 EDT by Hubert Kario
Modified: 2013-06-20 08:27 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 953199 976349 (view as bug list)
Environment:
Last Closed: 2013-05-21 04:17:29 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Hubert Kario 2013-04-17 11:32:50 EDT
Description of problem:
While updating package environment-modules changes to environment scripts are not preserved.

Version-Release number of selected component (if applicable):
environment-modules-3.2.9c-4.el6.x86_64

How reproducible:
Always

Steps to Reproduce:
1. Install environment-modules
2. Change /etc/profile.d/modules.csh or /etc/profile.d/modules.sh
3. Perform package reinstall
  
Actual results:
All changes to files are lost.

Expected results:
Changes should be preserved

Additional info:
Present also on Fedora 18
Comment 7 errata-xmlrpc 2013-05-21 04:17:29 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0844.html

Note You need to log in before you can comment on or make changes to this bug.