Bug 953210 - bash: _yum_complete_baseopts: command not found
Summary: bash: _yum_complete_baseopts: command not found
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: yum-utils
Version: 19
Hardware: All
OS: Linux
unspecified
medium
Target Milestone: ---
Assignee: Packaging Maintenance Team
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 953774 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-04-17 15:52 UTC by Mark Hamzy
Modified: 2013-05-22 03:19 UTC (History)
7 users (show)

Fixed In Version: yum-utils-1.1.31-14.fc19
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2013-05-22 03:19:00 UTC


Attachments (Terms of Use)

Description Mark Hamzy 2013-04-17 15:52:37 UTC
[root@sharpie ~]# yum groupinstall -y @buildsys-build
[root@sharpie ~]# yumdownloader --source kernel
[root@sharpie ~]# yum-builddep kernel-<press the Tab key>
bash: _yum_complete_baseopts: command not found

[root@sharpie ~]# rpm -qa | grep yum
yum-metadata-parser-1.1.4-8.fc19.ppc64
PackageKit-yum-plugin-0.8.7-3.fc19.ppc64
yum-3.4.3-81.fc19.noarch
anaconda-yum-plugins-1.0-9.fc19.noarch
yum-utils-1.1.31-12.fc19.noarch
PackageKit-yum-0.8.7-3.fc19.ppc64
yum-langpacks-0.3.1-1.fc19.noarch

[root@sharpie ~]# grep -r yum_complete_baseopts /etc
/etc/bash_completion.d/yum-utils.bash:    _yum_complete_baseopts "$cur" "$prev" 2>/dev/null && return 0
/etc/bash_completion.d/yum-utils.bash:    _yum_complete_baseopts "$cur" "$prev" && return 0
/etc/bash_completion.d/yum-utils.bash:    _yum_complete_baseopts "$cur" "$prev" && return 0
/etc/bash_completion.d/yum-utils.bash:    _yum_complete_baseopts "$cur" "$prev" 2>/dev/null && return 0

Comment 1 Zdeněk Pavlas 2013-04-18 08:22:42 UTC
Oh, great. yum-utils.bash assumes yum.bash is sourced in, too.  Fixed.  Thanks for the report!

Comment 2 Fedora Update System 2013-04-18 08:58:50 UTC
yum-utils-1.1.31-14.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/yum-utils-1.1.31-14.fc19

Comment 3 Fedora Update System 2013-04-18 17:26:53 UTC
Package yum-utils-1.1.31-14.fc19:
* should fix your issue,
* was pushed to the Fedora 19 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing yum-utils-1.1.31-14.fc19'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-5988/yum-utils-1.1.31-14.fc19
then log in and leave karma (feedback).

Comment 4 Zdeněk Pavlas 2013-04-19 07:49:16 UTC
*** Bug 953774 has been marked as a duplicate of this bug. ***

Comment 5 Fedora Update System 2013-05-22 03:19:00 UTC
yum-utils-1.1.31-14.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.