Bug 9533 - Pine is very slow when accessing folders that are on an nfs mounted volume
Pine is very slow when accessing folders that are on an nfs mounted volume
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: pine (Show other bugs)
6.1
i386 Linux
medium Severity low
: ---
: ---
Assigned To: pine
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-02-17 15:27 EST by Eve Kovacs
Modified: 2008-05-01 11:37 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-06-02 09:32:42 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Eve Kovacs 2000-02-17 15:27:40 EST
We have found a problem in the latest versions of pine..anything from
pine4.10-3 on, (including the beta version pine4.21 fro redhat 6.2). The
problem did not exist for pine4.10-1.

The problem is that pine is very slow opening the inbox, or accessing the
list of mail folders. In pine version 4.10-3, when we hit L, we get a busy
message...sometimes for 20 seconds, until the folder list comes up. In
pine version 4.21, we get a message saying "formatting scroll text" while
pine is grinding away. This problem occurs only for systems for which the
user home areas are on an nfs mounted volume. We have some systems which
the home areas are local to the machine. There, everything works fine.


So, I think the problem has to do with accessing folders on nfs mounted
volumes.
It could also be a network problem.

comparing the source for pine4.10-1 and
pine4.10-3, I noticed that the only differences were the extra patches
pine-3.96-sigchld.patch
pine-4.10-maildir.patch
in 4.10-3
and pine4.10-quote.patch which was present in 4.10-1 but not 4.10-3.
This latter looked inocuous, and pine-4.10-maildir.patch sounded like it
might have something to do with accessing mail folders or directories.
Comment 1 Trond Eivind Glomsrxd 2000-04-10 15:22:59 EDT
Have you tried the pine shipping with 6.2? Could you just switch between the
versions of pine to see if this really is the cause of the problem? (keeping
netowrk configuration, kernel etc. the same)
Comment 2 Trond Eivind Glomsrxd 2000-06-02 09:32:40 EDT
After an e-mail discussion with the reporter and an upgrade of the system, the
problem disappeared. I believe the problem to have been caused by NFS
configuration.

Note You need to log in before you can comment on or make changes to this bug.