Note: This bug is displayed in read-only format because
the product is no longer active in Red Hat Bugzilla.
RHEL Engineering is moving the tracking of its product development work on RHEL 6 through RHEL 9 to Red Hat Jira (issues.redhat.com). If you're a Red Hat customer, please continue to file support cases via the Red Hat customer portal. If you're not, please head to the "RHEL project" in Red Hat Jira and file new tickets here. Individual Bugzilla bugs in the statuses "NEW", "ASSIGNED", and "POST" are being migrated throughout September 2023. Bugs of Red Hat partners with an assigned Engineering Partner Manager (EPM) are migrated in late September as per pre-agreed dates. Bugs against components "kernel", "kernel-rt", and "kpatch" are only migrated if still in "NEW" or "ASSIGNED". If you cannot log in to RH Jira, please consult article #7032570. That failing, please send an e-mail to the RH Jira admins at rh-issues@redhat.com to troubleshoot your issue as a user management inquiry. The email creates a ServiceNow ticket with Red Hat. Individual Bugzilla bugs that are migrated will be moved to status "CLOSED", resolution "MIGRATED", and set with "MigratedToJIRA" in "Keywords". The link to the successor Jira issue will be found under "Links", have a little "two-footprint" icon next to it, and direct you to the "RHEL project" in Red Hat Jira (issue links are of type "https://issues.redhat.com/browse/RHEL-XXXX", where "X" is a digit). This same link will be available in a blue banner at the top of the page informing you that that bug has been migrated.
Description of problem:
virt-install seems to ignore the size parameter of the --disk option when creating an LVM volume.
Version-Release number of selected component (if applicable):
Source RPM: python-virtinst-0.600.0-15.el6.src.rpm
How reproducible:
100%
Only way to avoid is to manually pre-create the LVM volume with the desired size, and then reference it in the virt-install --disk parameter.
Steps to Reproduce:
1) create volume group named vg_vm_pool. Add it as a storage pool named vm_pool.
2) virt-install --os-type=linux --os-variant=rhel6 --bridge=br0 --disk pool=vm_pool,size=30 --location=<installServer> --name=mirror --ram=8192 --vcpus=1 --graphics type=none --extra-args console=ttyS0
Actual results:
Installation fails with some non-specific disk write errors on vda.
Additionally, LVM shows that the logical volume is 4MB in size, not 30GB. I suspect that it defaulted to allocating a single extent.
[root@server5 ~]# lvs
LV VG Attr LSize Pool Origin Data% Move Log Cpy%Sync Convert
lv_root vg_server5 -wi-ao--- 42.97g
mirror.img vg_vm_pool swi-aos-- 4.00m [mirror.img_vorigin] 0.00
Expected results:
A logical volume that is 30G in size, and a virt-install that succeeds.
Comment 1Martin Kletzander
2013-04-18 09:58:54 UTC
This problem is being dealt with in bug 921480 already, so I'm closing it as a duplicate.
*** This bug has been marked as a duplicate of bug 921480 ***