Bug 953352 - [abrt] pulseaudio-3.0-7.fc19: snd_pcm_area_copy: Process /usr/bin/pulseaudio was killed by signal 6 (SIGABRT)
[abrt] pulseaudio-3.0-7.fc19: snd_pcm_area_copy: Process /usr/bin/pulseaudio ...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: alsa-lib (Show other bugs)
19
i686 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Jaroslav Kysela
Fedora Extras Quality Assurance
abrt_hash:ad26feff9365db0aa66d906443e...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-04-17 22:33 EDT by German Ruiz
Modified: 2013-06-02 23:44 EDT (History)
5 users (show)

See Also:
Fixed In Version: alsa-lib-1.0.27.1-2.fc19
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-06-02 23:44:15 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (18.77 KB, text/plain)
2013-04-17 22:33 EDT, German Ruiz
no flags Details
File: cgroup (131 bytes, text/plain)
2013-04-17 22:33 EDT, German Ruiz
no flags Details
File: dso_list (6.82 KB, text/plain)
2013-04-17 22:33 EDT, German Ruiz
no flags Details
File: environ (1.40 KB, text/plain)
2013-04-17 22:33 EDT, German Ruiz
no flags Details
File: limits (1.29 KB, text/plain)
2013-04-17 22:33 EDT, German Ruiz
no flags Details
File: maps (20.35 KB, text/plain)
2013-04-17 22:33 EDT, German Ruiz
no flags Details
File: open_fds (1.72 KB, text/plain)
2013-04-17 22:33 EDT, German Ruiz
no flags Details
File: proc_pid_status (795 bytes, text/plain)
2013-04-17 22:33 EDT, German Ruiz
no flags Details
File: var_log_messages (9.01 KB, text/plain)
2013-04-17 22:33 EDT, German Ruiz
no flags Details

  None (edit)
Description German Ruiz 2013-04-17 22:33:10 EDT
Description of problem:
Just playing a youtube video...

Version-Release number of selected component:
pulseaudio-3.0-7.fc19

Additional info:
backtrace_rating: 4
cmdline:        /usr/bin/pulseaudio --start
core_backtrace: 
crash_function: snd_pcm_area_copy
executable:     /usr/bin/pulseaudio
kernel:         3.9.0-0.rc6.git2.3.fc19.i686
runlevel:       N 5
uid:            1001
ureports_counter: 1

Truncated backtrace:
Thread no. 1 (9 frames)
 #5 snd_pcm_area_copy at pcm.c:2719
 #6 snd_pcm_areas_copy at pcm.c:2865
 #7 softvol_convert_stereo_vol at pcm_softvol.c:291
 #8 snd_pcm_softvol_write_areas at pcm_softvol.c:607
 #9 snd_pcm_plugin_mmap_commit at pcm_plugin.c:424
 #10 snd_pcm_mmap_commit at pcm.c:6631
 #11 mmap_write at modules/alsa/alsa-sink.c:640
 #12 thread_func at modules/alsa/alsa-sink.c:1707
 #13 internal_thread_func at pulsecore/thread-posix.c:83
Comment 1 German Ruiz 2013-04-17 22:33:24 EDT
Created attachment 737110 [details]
File: backtrace
Comment 2 German Ruiz 2013-04-17 22:33:28 EDT
Created attachment 737111 [details]
File: cgroup
Comment 3 German Ruiz 2013-04-17 22:33:30 EDT
Created attachment 737112 [details]
File: dso_list
Comment 4 German Ruiz 2013-04-17 22:33:33 EDT
Created attachment 737113 [details]
File: environ
Comment 5 German Ruiz 2013-04-17 22:33:35 EDT
Created attachment 737114 [details]
File: limits
Comment 6 German Ruiz 2013-04-17 22:33:37 EDT
Created attachment 737115 [details]
File: maps
Comment 7 German Ruiz 2013-04-17 22:33:40 EDT
Created attachment 737116 [details]
File: open_fds
Comment 8 German Ruiz 2013-04-17 22:33:42 EDT
Created attachment 737117 [details]
File: proc_pid_status
Comment 9 German Ruiz 2013-04-17 22:33:45 EDT
Created attachment 737118 [details]
File: var_log_messages
Comment 10 Sergei 2013-05-06 16:14:00 EDT
Don't work sound after lowing down (sound off) in Xfce audio mixer.
After pressing fn+f8 sound works again.

backtrace_rating: 4
cmdline:        /usr/bin/pulseaudio --start
core_backtrace: 
crash_function: snd_pcm_area_copy
executable:     /usr/bin/pulseaudio
kernel:         3.9.0-301.fc19.i686
package:        pulseaudio-3.0-7.fc19
reason:         Process /usr/bin/pulseaudio was killed by signal 6 (SIGABRT)
runlevel:       N 5
uid:            1000
ureports_counter: 1
xsession_errors:
Comment 11 Rex Dieter 2013-05-06 16:59:36 EDT
Looks like hitting some assert before an attempt at memcpy inside alsa-lib's pcm.c
Comment 12 Jaroslav Kysela 2013-05-07 03:32:36 EDT
From backtrace: The softvol plugin ring buffer offset is desynchronized. PA asks to write to 38560 but the softvol plugin tries to move this data to 38568. The assert is just the final notice that something goes wrong.

It may be helpful to get snd_pcm_dump() info just before the assert().
Comment 13 Fedora Update System 2013-05-30 10:02:57 EDT
alsa-lib-1.0.27.1-2.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/alsa-lib-1.0.27.1-2.fc19
Comment 14 Fedora Update System 2013-05-31 14:07:56 EDT
Package alsa-lib-1.0.27.1-2.fc19:
* should fix your issue,
* was pushed to the Fedora 19 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing alsa-lib-1.0.27.1-2.fc19'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-9719/alsa-lib-1.0.27.1-2.fc19
then log in and leave karma (feedback).
Comment 15 Fedora Update System 2013-06-02 23:44:15 EDT
alsa-lib-1.0.27.1-2.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.