Bug 9535 - Mutt does not seem to use macros
Summary: Mutt does not seem to use macros
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: mutt   
(Show other bugs)
Version: 6.2
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-02-17 22:09 UTC by ivan
Modified: 2014-03-17 02:12 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-03-29 17:33:22 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description ivan 2000-02-17 22:09:44 UTC
The urlview and documentation macros (at least) do not seem to work, where
they worked fine in RH6.1. Muttrc seems fine, so it may be a compile-time
setting incorrect(?)

Comment 1 Bill Nottingham 2000-02-17 22:11:59 UTC
Hmm... works fine for me here. Under what sort of terminal
are you running mutt?

Comment 2 ivan 2000-02-17 22:43:59 UTC
gnome-terminal. I've just tried xterm, and that throws up the same error. The
documentation macro <f1> does not throw up an error, but \cb (urlview) throws up
"Key is not bound.  Press '?' for help.

Comment 3 ivan 2000-02-17 22:56:59 UTC
... not sure whether it is much help - a truss of the process as I hit "CTRL-b":

======================================
[ivan@ivan ivan]$ strace -p 1985
select(4, [3], NULL, NULL, {9, 790000}) = 1 (in [3], left {6, 440000})
read(3, "\2", 1)                        = 1
write(1, "\33[?25h\7", 7)               = 7
write(1, "\33[24;39H", 8)               = 8
write(1, "\33[?25l\33[23;80H", 14)      = 14
select(4, [3], NULL, NULL, {10, 0} <unfinished ...>
======================================
(the "<unfinished>" is when I hit CTRL-C on the truss)

Comment 4 Bill Nottingham 2000-03-20 17:39:59 UTC
Does this still fail with the rawhide ncurses/gnome-core packages?

It *sounds* like a terminfo problem.

Comment 5 Bill Nottingham 2000-03-29 17:33:59 UTC
This should be fixed with the mutt package in rawhide; it
wasn't reading /etc/Muttrc.


Note You need to log in before you can comment on or make changes to this bug.