Bug 953641 - gcr-3.6.2-3 breaks password prompt/keyring unlock
Summary: gcr-3.6.2-3 breaks password prompt/keyring unlock
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: gcr
Version: 18
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Matthias Clasen
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 952483 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-04-18 18:36 UTC by Milan Crha
Modified: 2013-11-06 03:05 UTC (History)
11 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2013-11-06 03:05:21 UTC
Type: Bug


Attachments (Terms of Use)

Description Milan Crha 2013-04-18 18:36:32 UTC
After update to gcr-3.6.2-3.fc18, together with gnome-keyring-3.6.3-1, I'm no longer asked for a keyring unlock and other password prompts (like from evolution 3.8 testing repo) under KDE. I tested this with seahorse, which seems to be the easiest way of testing this.

Steps:
a) update to gcr-3.6.2-3.fc18
b) kill running gnome-keyring-daemon, if any
c) run seahorse
d) View->By Keyring
e) if your Password keyring (most likely Default) is unlocked, then Lock it
f) right-click the Password->Default and choose Unlock

See nothing happens, while one should get a prompt to unlock his/her keyring.

g) close seahorse
h) yum downgrade gcr (you should get 3.6.2-1.fc18)
i) kill running gnome-keyring-daemon
j) run seahorse
k) right-click the Password->Default and choose Unlock

This time the keyring password prompt is shown.

Comment 1 Dr. Gregory R. Kriehn 2013-04-18 19:53:58 UTC
I can verify this bug as well.  Downgrading gcr allowed evolution to prompt for a new SMTP password after the old one was changed, which it would not do under gcr-3.6.2-3.fc18.  I examined keyring in seahorse and noted that evolution updated the keyring with the new password under gcr-3.6.2-1.fc18.

Comment 2 Milan Crha 2013-04-19 06:08:22 UTC
*** Bug 952483 has been marked as a duplicate of this bug. ***

Comment 3 Milan Crha 2013-04-19 06:13:50 UTC
I just found out that this is kind of known within bug #907156.

Comment 4 Fedora Update System 2013-04-22 12:42:28 UTC
gcr-3.6.2-4.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/gcr-3.6.2-4.fc18

Comment 5 Milan Crha 2013-04-24 15:54:15 UTC
The update fixes the password prompt, I'm asked for a password, but the keyring is not unlocked, thus the password I entered is not saved. This is still better than no password prompt at all.

Comment 6 Tobias Mueller 2013-05-15 18:01:30 UTC
hm. I can lock and unlock. I am not prompted for a password. Maybe I have none set up. But the keyring apparently locks and unlocks properly.

Comment 7 Milan Crha 2013-05-16 07:39:05 UTC
(In reply to comment #6)
> hm. I can lock and unlock. I am not prompted for a password. Maybe I have
> none set up. But the keyring apparently locks and unlocks properly.

What is your gcr version?

Comment 8 Tobias Mueller 2013-05-17 23:25:19 UTC
3.6.2-3.fc18

Comment 9 Milan Crha 2013-05-23 06:00:13 UTC
(In reply to Tobias Mueller from comment #8)
> 3.6.2-3.fc18

My comment #5 was for version from comment #4, thus gcr-3.6.2-4.fc18

Comment 10 Tim Wegener 2013-05-26 08:49:22 UTC
gcr-3.6.2-4.fc18.x86_64 fixed the problem for me (after rebooting).

Comment 11 Fedora Update System 2013-05-27 00:27:43 UTC
gcr-3.6.2-4.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 12 Sergio Basto 2013-11-06 03:05:21 UTC
(In reply to Fedora Update System from comment #11)
> gcr-3.6.2-4.fc18 has been pushed to the Fedora 18 stable repository.  If
> problems still persist, please make note of it in this bug report.

the bug should have been automatically closed


Note You need to log in before you can comment on or make changes to this bug.