Bug 953670 - CVE-2013-1951 mediawiki116 various flaws [epel-all]
CVE-2013-1951 mediawiki116 various flaws [epel-all]
Status: CLOSED NEXTRELEASE
Product: Fedora EPEL
Classification: Fedora
Component: mediawiki116 (Show other bugs)
el6
All Linux
medium Severity medium
: ---
: ---
Assigned To: Stephen John Smoogen
Fedora Extras Quality Assurance
: Security, SecurityTracking
Depends On:
Blocks: CVE-2013-1951 CVE-2013-2031/CVE-2013-2032
  Show dependency treegraph
 
Reported: 2013-04-18 16:56 EDT by Vincent Danen
Modified: 2013-05-08 15:50 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Release Note
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-05-08 15:50:05 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Vincent Danen 2013-04-18 16:56:06 EDT
This is an automatically created tracking bug!  It was created to ensure
that one or more security vulnerabilities are fixed in affected versions
of Fedora EPEL.

For comments that are specific to the vulnerability please use bugs filed
against the "Security Response" product referenced in the "Blocks" field.

For more information see:
http://fedoraproject.org/wiki/Security/TrackingBugs

When creating a Bodhi update request, please use the bodhi submission link
noted in the next comment(s).  This will include the bug IDs of this
tracking bug as well as the relevant top-level CVE bugs.

Please also mention the CVE IDs being fixed in the RPM changelog and the
Bodhi notes field when available.

Please note: this issue affects multiple supported versions of Fedora EPEL.
Only one tracking bug has been filed; please ensure that it is only closed
when all affected versions are fixed.

[bug automatically created by: add-tracking-bugs]
Comment 1 Vincent Danen 2013-04-18 16:56:15 EDT
Please use the following update submission link to create the Bodhi
request for this issue as it contains the top-level parent bug(s) as well
as this tracking bug.  This will ensure that all associated bugs get
updated when new packages are pushed to stable.

Please also ensure that the "Close bugs when update is stable" option
remains checked.

Bodhi update submission link:
https://admin.fedoraproject.org/updates/new/?type_=security&bugs=953666,953670
Comment 2 Patrick Uiterwijk 2013-04-19 04:36:18 EDT
There has been no release for mediawiki 1.16, which this package represents.
Also, this package should definitely be dead.package'd.
We could maybe add a provides and obsoletes to mediawiki119 so that updates silently move to this version (in EPEL-6 branch only though)?
Comment 3 Vincent Danen 2013-04-22 15:18:48 EDT
Right, that's because 1.16 is dead upstream.

Removing this package and making the latest version provide/obsolete it would definitely be better.  We can't know for 100% whether or not this version is affected, but there's a pretty good chance it is.
Comment 4 Vincent Danen 2013-04-30 16:57:47 EDT
Adding parent bug 958303.  Please use this new bodhi update url when correcting
these flaws:

https://admin.fedoraproject.org/updates/new/?type_=security&bugs=953670,953666,958303
Comment 5 Patrick Uiterwijk 2013-05-08 15:50:05 EDT
mediawiki116 has been dead.package'd, and provides/obsoletes has been added to mediawiki (for f17, f18, f19) and the mediawiki119 (for el6).

Note You need to log in before you can comment on or make changes to this bug.