Bug 953948 - ruby_version shouldn't be empty
ruby_version shouldn't be empty
Status: CLOSED DUPLICATE of bug 923703
Product: Fedora
Classification: Fedora
Component: ruby (Show other bugs)
19
All Linux
high Severity high
: ---
: ---
Assigned To: Jeroen van Meeuwen
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-04-19 11:34 EDT by Karsten Hopp
Modified: 2013-04-22 03:15 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-04-22 03:15:41 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Karsten Hopp 2013-04-19 11:34:24 EDT
Description of problem:
ruby -r rbconfig -e "print RbConfig::CONFIG['ruby_version']"
 prints nothing with ruby-2.0. It prints '1.9.1' with F18 ruby.

Version-Release number of selected component (if applicable):
ruby-2.0.0.0-6.fc19.x86_64

How reproducible:
always

Steps to Reproduce:
1. ruby -r rbconfig -e "print RbConfig::CONFIG['ruby_version']"
2.
3.
  
Actual results:
no output

Expected results:
2.0.0

Additional info:
This breaks p.e. the latest vim from f19 git. autoconf tries to figure out the ruby libraries and versions and ends up with this:
 -DDYNAMIC_RUBY_DLL=\"libruby.so.2.0.0\" -DDYNAMIC_RUBY_VER= -I/usr/include

This should be 
 -DDYNAMIC_RUBY_DLL=\"libruby.so.2.0.0\" -DDYNAMIC_RUBY_VER=20 -I/usr/include
Comment 1 Vít Ondruch 2013-04-22 03:15:41 EDT

*** This bug has been marked as a duplicate of bug 923703 ***

Note You need to log in before you can comment on or make changes to this bug.