Bug 953994 - virt-v2v failing for VMware guest on vmware-tools-foundation dependency
Summary: virt-v2v failing for VMware guest on vmware-tools-foundation dependency
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: virt-v2v
Version: 6.4
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: rc
: ---
Assignee: Matthew Booth
QA Contact: Virtualization Bugs
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-04-19 19:53 UTC by Dustin Black
Modified: 2018-12-04 15:15 UTC (History)
6 users (show)

Fixed In Version: virt-v2v-0.9.1-1.el6
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2013-11-21 05:39:06 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2013:1547 normal SHIPPED_LIVE virt-v2v bug fix and enhancement update 2013-11-20 21:40:38 UTC

Description Dustin Black 2013-04-19 19:53:27 UTC
Description of problem:
Converting ESX RHEL VM's to KVM VM's, the process is failing possibly because the version of vmware-tools in use is later than the code can cope with.

This has been tried with both the vmware-tools packages installed on the VM and un-installed, each time resulting in this sort of messages in the error logs:

command: command: error: Failed dependencies:
        vmware-tools-foundation >= 0:9.0.1 is needed by (installed)         vmware-tools-libraries-nox-0:9.0.1-2.x86_64 at /usr/share/perl5/vendor_perl/Sys/VirtConvert/GuestfsHandle.pm line 204.


The v2v code doesn't attempt to remove the vmware-tools-libraries-nox package, hence the error.


Version-Release number of selected component (if applicable):
virt-v2v-0.8.9-2.el6.x86_64

How reproducible:
Consistently on same systems, with and without vmware tools on the guest.

Steps to Reproduce:
Conversion command is:
virt-v2v -ic ${ESXHOST}         \
         -os ${STROAGEPOOL}      \
         -oa "sparse"            \
         -of "raw"               \
         --bridge "bridge1"      \
         -on ${ESXVM}-v2v        \
         ${ESXVM}
  
Actual results:
Conversion fails with:
command: command: error: Failed dependencies:
        vmware-tools-foundation >= 0:9.0.1 is needed by (installed)         vmware-tools-libraries-nox-0:9.0.1-2.x86_64 at /usr/share/perl5/vendor_perl/Sys/VirtConvert/GuestfsHandle.pm line 204.


Expected results:
Conversion succeeds.

Additional info:

Comment 3 Dustin Black 2013-04-19 20:03:04 UTC
Problem observed with: ESX 5.0 build 768111

Comment 5 tingting zheng 2013-04-22 06:26:05 UTC
I can reproduce this issue with virt-v2v-0.8.9-2.el6.x86_64:

# virt-v2v  -ic esx://10.66.6.211/?no_verify=1 -os default  esx5.1-rhel6-x64-vmware-toolesx5.0-template-test_esx5.0-template-test: 100% [======================================================]D 0h03m51s
virt-v2v: WARNING: Failed to install replacement dependencies for vmware-tools-libraries-nox. Package will not be uninstalled. Error was: command: command: Error: Need to pass a list of pkgs to install at /usr/share/perl5/vendor_perl/Sys/VirtConvert/GuestfsHandle.pm line 204.
 at /usr/share/perl5/vendor_perl/Sys/VirtConvert/Converter/RedHat.pm line 1094

virt-v2v: WARNING: Failed to install replacement dependencies for vmware-tools-libraries-x. Package will not be uninstalled. Error was: command: command: Error: Need to pass a list of pkgs to install at /usr/share/perl5/vendor_perl/Sys/VirtConvert/GuestfsHandle.pm line 204.
 at /usr/share/perl5/vendor_perl/Sys/VirtConvert/Converter/RedHat.pm line 1094

command: command: error: Failed dependencies:
	vmware-tools-foundation >= 0:9.0.1 is needed by (installed) vmware-tools-libraries-nox-0:9.0.1-2.x86_64
	vmware-tools-foundation >= 0:9.0.1 is needed by (installed) vmware-tools-libraries-x-0:9.0.1-2.x86_64 at /usr/share/perl5/vendor_perl/Sys/VirtConvert/GuestfsHandle.pm line 204.
 at /usr/share/perl5/vendor_perl/Sys/VirtConvert/Converter/RedHat.pm line 895

Comment 7 Matthew Booth 2013-06-10 14:40:01 UTC
This is fixed upstream.

Comment 10 tingting zheng 2013-06-14 08:47:43 UTC
Tested with:
virt-v2v-0.9.1-1.el6_5.x86_64
libvirt-0.10.2-18.el6_4.8.x86_64
libguestfs-1.20.8-5.el6.x86_64

# virt-v2v  -ic esx://10.66.6.211/?no_verify=1 -os default  esx5.1-rhel6-x64-vmware-tool
esx5.0-template-test_esx5.0-template-test: 100% [======================================================]D 0h03m56s
virt-v2v: esx5.1-rhel6-x64-vmware-tool configured with virtio drivers.

After conversion,the guest can boot successfully.

So mark the status of the bug as VERIFIED.

Comment 15 errata-xmlrpc 2013-11-21 05:39:06 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1547.html


Note You need to log in before you can comment on or make changes to this bug.