Bug 954183 - [NetKVM] Static driver verifier fails with NetKVM
Summary: [NetKVM] Static driver verifier fails with NetKVM
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: virtio-win
Version: 7.0
Hardware: Unspecified
OS: Windows
unspecified
medium
Target Milestone: rc
: 7.0
Assignee: Yan Vugenfirer
QA Contact: Virtualization Bugs
URL:
Whiteboard:
Depends On:
Blocks: 1288337
TreeView+ depends on / blocked
 
Reported: 2013-04-21 16:50 UTC by Yan Vugenfirer
Modified: 2016-11-04 08:42 UTC (History)
11 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
NO_DOCS
Clone Of:
Environment:
Last Closed: 2016-11-04 08:42:57 UTC
Target Upstream Version:


Attachments (Terms of Use)
The static verifier output files ans console log (55.87 KB, application/zip)
2015-03-11 15:05 UTC, Yossi Hindin
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:2609 normal SHIPPED_LIVE virtio-win bug fix and enhancement update 2016-11-03 15:27:12 UTC

Description Yan Vugenfirer 2013-04-21 16:50:55 UTC
Description of problem:

Driver verification log is part of WHQL submission.

For now MS doesn't require it to pass, but it will in the future and SDV can show real code issues.

For now it fails without actual run because of lack of SDV annotations needed in the code.


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

Comment 5 Vadim Rozenfeld 2015-03-11 01:04:59 UTC
Should be fixed in build 102 available from
http://download.devel.redhat.com/brewroot/packages/virtio-win-prewhql/0.1/102/win/virtio-win-prewhql-0.1.zip

Comment 8 Yossi Hindin 2015-03-11 15:01:55 UTC
After the Visual Studio project was fixed, the static analyzer still fails with the following message:
3/11/2015 4:52:47 PM:  ** Esp: EspCxxDrv failure (cfg): skipping function '__FallThrough'.

3/11/2015 4:52:47 PM: C:\Program Files (x86)\Windows Kits\8.1\Include\shared\sal.h(2900) : fatal error C1001: An internal error has occurred in the compiler.

3/11/2015 4:52:48 PM:SDV encountered errors when scanning the driver. Please ensure roletypes are present and/or consult SDV documentation.

The archive with log and output files is attached.

Comment 9 Yossi Hindin 2015-03-11 15:05:05 UTC
Created attachment 1000536 [details]
The static verifier output files ans console log

Comment 10 Vadim Rozenfeld 2015-05-24 06:21:48 UTC
please check with the latest build, available at 
http://download.devel.redhat.com/brewroot/packages/virtio-win-prewhql/0.1/104/win/virtio-win-prewhql-0.1.zip

Comment 11 Yan Vugenfirer 2015-05-24 12:28:37 UTC
The build in comment 10 include only partial changes.

Comment 18 Yu Wang 2016-06-14 06:33:23 UTC
According to Netkvm WHQL Test Result on build 117, all the "Static tools logo test" have been passed in HCK and HLK kits.

Above all, this bug has been fixed.

Thanks
Yu Wang

Comment 19 Yu Wang 2016-06-14 06:34:49 UTC
change status to "verified" according to comment#17 and comment#18

Thanks
Yu Wang

Comment 22 errata-xmlrpc 2016-11-04 08:42:57 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-2609.html


Note You need to log in before you can comment on or make changes to this bug.