Bug 954262 - virt-install should fall back to use hardcoded paths when .treeinfo lacks images-ARCH section
Summary: virt-install should fall back to use hardcoded paths when .treeinfo lacks ima...
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: python-virtinst
Version: 6.5
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Martin Kletzander
QA Contact: Virtualization Bugs
URL:
Whiteboard:
Keywords: TestBlocker
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-04-22 06:24 UTC by Monson Shao
Modified: 2014-12-15 15:07 UTC (History)
10 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2013-11-21 10:37:41 UTC


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2013:1604 normal SHIPPED_LIVE python-virtinst bug fix and enhancement update 2013-11-20 21:39:12 UTC

Description Monson Shao 2013-04-22 06:24:52 UTC
Description of problem:

When using virt-install to install a RHEL4 guest, it fails with
'''
Thu, 18 Apr 2013 10:39:03 ERROR    No section: 'images-x86_64'
'''

It's because the .treeinfo for RHEL4, e.g. [1], lacks [images-x86_64]
section, which is expected in RHEL5 or above. However, it should fall
back use the default hardcoded value instead of failing:

initrd = images/pxeboot/initrd.img
kernel = images/pxeboot/vmlinuz

That's what Beaker does it now.

[1] http://download.devel.redhat.com/released/RHEL-4/U9/AS/x86_64/tree/.treeinfo
[2] job link: https://beaker.engineering.redhat.com/jobs/406215
[3] virt-install log: http://beaker-archive.app.eng.bos.redhat.com/beaker-logs/2013/04/4062/406215/854976/12026797/kvm_x86_64_1_install.log

Version-Release number of selected component (if applicable):
python-virtinst-0.600.0-15.el6.noarch

How reproducible:
100%

Steps to Reproduce:
1. using virt-install to install a RHEL4 guest on kvm host
  
Actual results:
virt-install fail

Expected results:
virt-install success

Additional info:

Comment 2 Martin Kletzander 2013-04-22 14:59:56 UTC
Patch proposed upstream:
https://www.redhat.com/archives/virt-tools-list/2013-April/msg00214.html

Comment 4 Martin Kletzander 2013-04-23 12:21:17 UTC
Moving to POST per commit virtinst-0_600_4-2-g1ca4fc1 in python-virtinst maintenance branch:

commit 1ca4fc1945c6aefe0d97b21b2f0f2bffc14bb3db
Author: Martin Kletzander <mkletzan@redhat.com>
Date:   Mon Apr 22 16:54:57 2013 +0200

    Support incomplete .treeinfo files

Comment 7 hyao@redhat.com 2013-07-04 05:53:06 UTC
Reproduce the bug on rhel7 with the following packages:

#rpm -qa virt-manager libvirt
 virt-manager-0.9.0-18.el6.x86_64
libvirt-0.10.2-18.el6_4.9.x86_64

Comment 8 hyao@redhat.com 2013-07-04 06:08:01 UTC
(In reply to hyao@redhat.com from comment #7)
> Reproduce the bug on rhel7 with the following packages:
> 
> #rpm -qa virt-manager libvirt
>  virt-manager-0.9.0-18.el6.x86_64
> libvirt-0.10.2-18.el6_4.9.x86_64

reproduced on rhel6 not rhel7

Comment 13 hyao@redhat.com 2013-07-22 08:55:28 UTC
the bug is fixed on the following version

#rpm -qa libvirt python-virtinst
python-virtinst-0.600.0-17.el6.noarch
libvirt-0.10.2-21.el6.x86_64

Comment 14 errata-xmlrpc 2013-11-21 10:37:41 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1604.html


Note You need to log in before you can comment on or make changes to this bug.