Bug 9543 - / mount race on boot!
/ mount race on boot!
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: initscripts (Show other bugs)
6.1
All Linux
medium Severity high
: ---
: ---
Assigned To: Bill Nottingham
:
: 9544 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-02-18 02:56 EST by lars
Modified: 2014-03-16 22:12 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-02-18 11:11:48 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description lars 2000-02-18 02:56:18 EST
Good morning. Checking indicates this bug is not yet known.

If you by chance (in our case it appeared to involve an unclean NFS
shutdown or whatever) end up with /etc/mtab, mtab~ and mtab~~, your system
will hang directly after remounting / rw. No error message will be given,
it will just hang and loop.

(This is mount trying to create its lockfile for mtab and failing)

How to reproduce easily:
touch /etc/mtab /etc/mtab~ /etc/mtab~~
sync ; shutdown -f (or flip the reset button;)

Quite an annoying error to track down, since it follows even a cp -a of the
root fs to a new partition (one of the first suspects of a box hanging
after remounting / rw is a ext2 error of some sort...)

initscripts should do something about that (remove mtab*), and mount should
_probably_ complain about it instead of silently looping forever.
Comment 1 Alan Cox 2000-02-18 06:20:59 EST
*** Bug 9544 has been marked as a duplicate of this bug. ***
Comment 2 Bill Nottingham 2000-02-18 11:11:59 EST
This is fixed as of initscripts-4.84 and above.

Note You need to log in before you can comment on or make changes to this bug.