Bug 9547 - ~/.Xmodmap and /etc/X11/xinit/Xmodmap not loaded
~/.Xmodmap and /etc/X11/xinit/Xmodmap not loaded
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: XFree86 (Show other bugs)
6.2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Preston Brown
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-02-18 08:22 EST by Tomasz Kepczynski
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-02-21 12:28:09 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tomasz Kepczynski 2000-02-18 08:22:14 EST
After upgrade 6.1 -> 6.1.92 kdm ceased to load user's and system
Xmodmap file. The problem is related to fact that Xsesion file attempts
to set xkb map first and incorrectly sets flag that xkb is in use.
This happens because sysxkbmap (if I remember correctly) shell variable is
unassigned and is not quoted in if statements. For some reason bash
treats "[ -f $sysxkbmap ]" as true under this circumstances.
The problem probably also exists in xinitrc.
The simplest solution - quote all variables in scripts.
Comment 1 Preston Brown 2000-02-21 12:28:59 EST
fixed in XFree86-3.3.6-14 and later.

Note You need to log in before you can comment on or make changes to this bug.