Bug 9555 - eepro100 interfaces on two Compaq E700's show same MAC Address
eepro100 interfaces on two Compaq E700's show same MAC Address
Status: CLOSED ERRATA
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
6.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Michael K. Johnson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-02-18 10:35 EST by jmiller
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-08-04 16:58:01 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description jmiller 2000-02-18 10:35:15 EST
We have two identical Compaq notebooks with integrated eepro100 ethernet
interfaces.  under Redhat 6.1, these interfaces come up with the same MAC
address resulting in major network problems.  Under Windows, the interfaces
report different addresses and the problem is not present.

I see that the hw address is configurable on the command line for ifconfig,
but doing it manually messes up the rc.d structure and also rules out dhcp
addresses.  Is there a way to put HW Address into the
/etc/sysconfig/network-scripts/ifcfg-eth0 file?

Is there a easy solution to this?
Comment 1 jmiller 2000-02-18 11:44:59 EST
compiled newer code from:
http://cesdis.gsfc.nasa.gov/linux/drivers/eepro100.html

This fixes the MAC Problem.
Comment 2 Michael K. Johnson 2000-08-04 16:57:59 EDT
Yes, you can put
MACADDR=<macaddress>
in the ifcfg-eth0 file

Does this problem still exist with the 2.2.16-3 errata
kernel?
Comment 3 Alan Cox 2000-09-23 18:34:18 EDT
No reply - assuming fixed

Note You need to log in before you can comment on or make changes to this bug.