Bug 955559 - Update to 0.9.2
Summary: Update to 0.9.2
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: python-xlrd
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Jan ONDREJ
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-04-23 09:36 UTC by Pierre-YvesChibon
Modified: 2013-05-04 01:43 UTC (History)
2 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2013-05-04 01:43:36 UTC


Attachments (Terms of Use)

Description Pierre-YvesChibon 2013-04-23 09:36:17 UTC
python-xlrd has a newer version 0.9.2, could it be pushed to devel and F19, maybe even F18?

Similarly, the 0.8.0 update brought the xslx support, would it be possible to have it on EL6?

Thanks!

Comment 1 Jan ONDREJ 2013-04-23 10:58:29 UTC
Hello. python-xlrd-0.9.2 built for fc20. I can build it for f19 too.

I am not sure, how compatible is version 0.9 with 0.8 or older, so don't know if I can build it for stable releases.

Comment 2 Pierre-YvesChibon 2013-04-23 11:12:16 UTC
I think it's worth building for F19 as well.

As far as I can see, the tutorial https://github.com/python-excel/tutorial did not change for a year while xlrd went from 0.7.* to 0.9.*
This would make me think that it's pretty safe to update on stable release but might be worth asking upstream for confirmation.

Comment 3 Jan ONDREJ 2013-04-29 10:26:41 UTC
Update to 0.9.2 has been confirmed by upstream:

https://groups.google.com/forum/?fromgroups=#!topic/python-excel/spuxw84E2m4

> There aren't any, because there are no changes. Applications written for
> 0.6.x will still work without change when using 0.9.2.

Comment 4 Fedora Update System 2013-04-29 10:59:27 UTC
python-xlrd-0.9.2-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/python-xlrd-0.9.2-1.fc18

Comment 5 Fedora Update System 2013-04-29 11:00:25 UTC
python-xlrd-0.9.2-1.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/python-xlrd-0.9.2-1.fc19

Comment 6 Fedora Update System 2013-04-29 11:10:41 UTC
python-xlrd-0.9.2-1.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/python-xlrd-0.9.2-1.fc17

Comment 7 Fedora Update System 2013-04-29 11:57:08 UTC
python-xlrd-0.9.2-1.el6 has been submitted as an update for Fedora EPEL 6.
https://admin.fedoraproject.org/updates/python-xlrd-0.9.2-1.el6

Comment 8 Pierre-YvesChibon 2013-04-29 12:09:03 UTC
Great news, thanks!

Comment 9 Fedora Update System 2013-04-29 17:43:16 UTC
Package python-xlrd-0.9.2-1.fc19:
* should fix your issue,
* was pushed to the Fedora 19 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing python-xlrd-0.9.2-1.fc19'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-6929/python-xlrd-0.9.2-1.fc19
then log in and leave karma (feedback).

Comment 10 Fedora Update System 2013-05-04 01:43:37 UTC
python-xlrd-0.9.2-1.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.