Bug 955575 - libvirt does not support virtualHW.version 9
Summary: libvirt does not support virtualHW.version 9
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: libvirt
Version: 6.5
Hardware: All
OS: Linux
unspecified
medium
Target Milestone: rc
: ---
Assignee: Martin Kletzander
QA Contact: Virtualization Bugs
URL:
Whiteboard:
Keywords: Upstream
Depends On: 929354
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-04-23 10:16 UTC by Richard W.M. Jones
Modified: 2018-12-02 17:49 UTC (History)
11 users (show)

(edit)
Cause: VirtualHW version 9 was not set as supported even though the corresponding ESX ersion (5.1) was set to be supported earlier.

Consequence: When connection was made to ESX 5.1 server with guest using virtualHW version 9, the user saw the following error:
internal error Expecting VMX entry 'virtualHW.version' to be 4, 7 or 8 but found 9

Fix: VirtualHW version 9 was added into the list of supported versions.

Result: User sees no such error as before.
Clone Of: 929354
(edit)
Last Closed: 2013-11-21 08:59:16 UTC


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2013:1581 normal SHIPPED_LIVE libvirt bug fix and enhancement update 2013-11-21 01:11:35 UTC
Red Hat Knowledge Base (Solution) 356593 None None None Never

Description Richard W.M. Jones 2013-04-23 10:16:51 UTC
+++ This bug was initially created as a clone of Bug #929354 +++

Description of problem:


Version-Release number of selected component (if applicable):


How reproducible: Very



Steps to Reproduce:
1. Try to import a VM from an esx host that has hardware version 9 using virt-v2v
2. 
3.
  
Actual results: libvirt responds with virtualHW.version 9 not supported


Expected results: VM is imported


Additional info:

--- Additional comment from Dan Kozlowski on 2013-03-29 20:05:42 EDT ---

This is not a virt-v2v bug, that is just the tool I used to trigger it. The offending lines are 1307 and 1308 of src/vmx/vmx.c

Comment 2 tingting zheng 2013-04-24 07:54:12 UTC
I can reproduce this issue.
version:
virt-v2v-0.8.9-2.el6.x86_64
libvirt-0.10.2-18.el6_4.4.x86_64

1.Update a guest to hardware version 9 on esx5.1.

2.Use virt-v2v to convert the guest.
# virt-v2v -ic esx://10.66.6.211/?no_verify=1 -os default esx5.1-rhel6-vmx9
libvirt error code: 1, message: internal error Expecting VMX entry 'virtualHW.version' to be 4, 7 or 8 but found 9

Comment 3 Martin Kletzander 2013-04-30 14:43:21 UTC
Patch proposed upstream:

http://www.redhat.com/archives/libvir-list/2013-April/msg02137.html

Comment 4 Martin Kletzander 2013-04-30 14:45:17 UTC
Ignore previous message, the proposal is in this one:

http://www.redhat.com/archives/libvir-list/2013-April/msg02131.html

Comment 5 Martin Kletzander 2013-04-30 15:07:41 UTC
Moving to POST:

commit e0eb672e0046af365a4039cc68311e5d844fc7bf
Author: Martin Kletzander <mkletzan@redhat.com>
Date:   Tue Apr 30 14:46:54 2013 +0200

    esx: Support virtualHW version 9

Comment 6 Jiri Denemark 2013-06-11 10:07:03 UTC
We decided not to rebase libvirt in RHEL 6.5 to avoid stability issues
we faced in 6.4. This bug has already been trivially fixed upstream but
it is not considered important enough to be backported to RHEL 6.5.

Thus I'm pushing this bug to RHEL 6.6 (and setting Upstream keyword to
indicate we have patches upstream) for now. If you don't agree with
this resolution, please, give us reasons which you think are strong
enough for us to reevaluate the decision not to backport patches for
this bug.

Comment 7 Richard W.M. Jones 2013-06-11 10:55:57 UTC
Come on, this is like a 4 line patch, and it *IS* very important
for virt-v2v users.  We have had several who have his this bug.

Comment 8 Jiri Denemark 2013-06-11 17:35:35 UTC
Oops, sorry about that Rich. This bug slipped from the important (and
trivial) list into the trivial and unimportant list. I'm moving it
back to 6.5.

Comment 16 tingting zheng 2013-07-10 05:30:49 UTC
Tested the bug with:
libvirt-0.10.2-19.el6.x86_64
virt-v2v-0.9.1-1.el6_5.x86_64

Steps:
1.Update a guest to hardware version 9 on esx5.1.

2.Use virt-v2v to convert the guest.
# virt-v2v -ic esx://10.66.6.211/?no_verify=1 -os default esx5.1-rhel6-vmx9
esx5.0-rhel6.2-x86_64_esx5.0-rhel6.2-x86_64: 100% [====================================================]D 0h03m46s
virt-v2v: WARNING: No mapping found for bridge interface VM Network in config file. The converted guest may not start until its network interface is updated.
virt-v2v: esx5.1-rhel6-vmx9 configured with virtio drivers.

Refer to above comments,move the bug as VERIFIED.

Comment 18 errata-xmlrpc 2013-11-21 08:59:16 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1581.html


Note You need to log in before you can comment on or make changes to this bug.